Bug 1923256 (CVE-2021-20216) - CVE-2021-20216 privoxy: Memory leak when decompression fails
Summary: CVE-2021-20216 privoxy: Memory leak when decompression fails
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2021-20216
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1923258
Blocks: 1928903
TreeView+ depends on / blocked
 
Reported: 2021-02-01 15:57 UTC by Pedro Sampaio
Modified: 2021-02-15 19:40 UTC (History)
3 users (show)

Fixed In Version: privoxy 3.0.31
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in Privoxy before version 3.0.31. A memory leak that occurs when decompression fails unexpectedly may lead to a denial of service. The highest threat from this vulnerability is to system availability.
Clone Of:
Environment:
Last Closed: 2021-02-01 20:42:11 UTC


Attachments (Terms of Use)

Description Pedro Sampaio 2021-02-01 15:57:20 UTC
A flaw was found in privoxy before version 3.0.31. A memory leak when decompression fails "unexpectedly" may lead to denial of service.

References:

https://www.openwall.com/lists/oss-security/2021/01/31/2

Comment 1 Pedro Sampaio 2021-02-01 15:57:49 UTC
Created privoxy tracking bugs for this issue:

Affects: fedora-all [bug 1923258]

Comment 2 Product Security DevOps Team 2021-02-01 20:42:11 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.