Bug 19236 - AIX shadow password magic doesn't work since RedHat 7.0
AIX shadow password magic doesn't work since RedHat 7.0
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: ypbind (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-17 04:41 EDT by Luca Bonomi
Modified: 2007-03-26 23:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-25 12:36:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luca Bonomi 2000-10-17 04:41:05 EDT
Hi,

I'm using an etherogeneus environment, where I share the passwd NIS map
between Linux and AIX and I use shadow passwords.
The magic for using the shadow passwords in AIX is "##username" as the 2^
field in the password entry. This magic used to work for Linux as well
until the 6.2 release. From RedHat 7.0 I'm not able to use shadow anymore,
because it requires the magic to be "x".

Thanks

Luca
Comment 1 Alexander Larsson 2002-03-25 12:36:49 EST
What exactly is it that doesn't work? Can't authenticate? Can't change password?

Also, can you try the latest stuff in rawhide and see if those work for you?
At least yppasswd has gotten some code to deal with this magic.

Comment 2 Alexander Larsson 2002-04-09 12:33:59 EDT
This is due to a behavior change between pam_pwdb and pam_unix -- pam_unix will
*never* look for a shadow password unless that field is 'x', otherwise there's
no way to know if there's supposed to be one there or not.

I recommend configuring pam to use pam_pwdb instead, which should fix this problem.

Note You need to log in before you can comment on or make changes to this bug.