This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 192372 - classpathx-jaf fails to build in mock
classpathx-jaf fails to build in mock
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: classpathx-jaf (Show other bugs)
rawhide
All Linux
urgent Severity medium
: ---
: ---
Assigned To: Fernando Nasser
:
Depends On: 198286
Blocks: BuildReqBlocker
  Show dependency treegraph
 
Reported: 2006-05-18 22:50 EDT by Michael J Knox
Modified: 2013-01-09 22:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-25 02:28:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Matt Domsch's buildlog (2.84 KB, text/plain)
2006-05-18 22:50 EDT, Michael J Knox
no flags Details

  None (edit)
Description Michael J Knox 2006-05-18 22:50:10 EDT
This package fails to build in mock.  build.log is attached.
Comment 1 Michael J Knox 2006-05-18 22:50:10 EDT
Created attachment 129574 [details]
Matt Domsch's buildlog
Comment 2 Gary Benson 2006-05-19 09:57:24 EDT
Do you know why /usr/lib/jvm/jre/bin/javac failed?
Comment 3 Michael J Knox 2006-05-19 18:28:10 EDT
That would be because there is no buildrequires for it.

From the config.log :

configure:1693: /usr/lib/jvm/jre/bin/javac  Test.java
./configure: line 1694: /usr/lib/jvm/jre/bin/javac: No such file or directory
configure:1696: $? = 127
configure:1700: error: The Java compiler /usr/lib/jvm/jre/bin/javac failed (see
config.log, check the CLASSPATH?)

From the mock enviroment :

[michael@leroy root]$ pwd
/var/lib/mock/fedora-development-i386-core/root
[michael@leroy root]$

[michael@leroy root]$ ls -l  usr/lib/jvm/jre/bin/
total 0
lrwxrwxrwx  1 root root 12 May  7 13:58 java -> /usr/bin/gij
lrwxrwxrwx  1 root root 21 May  7 13:58 rmiregistry -> /usr/bin/grmiregistry


Adding this fixes it:

BuildRequires: java-devel
Comment 5 Jesse Keating 2006-07-10 15:49:35 EDT
Ping.  A mass rebuild is scheduled for tomorrow, July 11th.  Please try to have
your package fixed by then.
Comment 6 Fernando Nasser 2006-07-10 16:49:58 EDT
We are currently having some difficulties on ppc64 and s390x.  If rebuilds
include those arches most java packages will fail to build:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=198286
Comment 7 Mike A. Harris 2006-07-25 02:28:36 EDT
Core Rawhide-in-Mock Build Results for x86_64 Mon Jul 24 16:05:03 CDT 2006

Note: This is using a reduced set of packages in the build chroot as
compared to the standard Fedora Extras build system before FC6test1.  See
http://fedoraproject.org/wiki/QA/FixBuildRequires for more
information, including the list of packages removed from the
default build chroot.


Open Bugs which now build, and can be marked CLOSED RAWHIDE:
classpathx-jaf-1.0-7jpp_2fc 192372 ASSIGNED
compat-gcc-296-2.96-136 191696 NEW
epiphany-2.15.1-2 191665 NEW
jakarta-commons-el-1.0-5jpp_2fc 192514 NEW
ldapjdk-4.17-1jpp_4fc 192530 NEW
pygobject2-2.11.0-2 197138 NEW
vorbis-tools-1.1.1-2 197076 NEW
zsh-4.2.5-2 191647 NEW


Note You need to log in before you can comment on or make changes to this bug.