RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1924001 - add support for proxy_username and proxy_password in microdnf
Summary: add support for proxy_username and proxy_password in microdnf
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: microdnf
Version: 8.4
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: 8.0
Assignee: Nicola Sella
QA Contact: Jan Blazek
URL:
Whiteboard:
Depends On: 1951409
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-02-02 12:15 UTC by Nicola Sella
Modified: 2021-11-10 09:18 UTC (History)
2 users (show)

Fixed In Version: libdnf-0.63.0-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-09 19:48:43 UTC
Type: Bug
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2021:4441 0 None None None 2021-11-09 19:48:45 UTC

Description Nicola Sella 2021-02-02 12:15:06 UTC
Description of problem:
This pr enables proxy_username and proxy_password for microdnf. without it some tests are failing

https://github.com/rpm-software-management/libdnf/pull/1103

Version-Release number of selected component (if applicable):
microdnf-3.4.0-3.el8

Steps to Reproduce:
run tests for 8.4 features/microdnf/error_messages.feature

Actual results:
    ./dnf-testing.sh -d run --noxfail features/microdnf/error_messages.feature  
    Feature: Test error messages # features/microdnf/error_messages.feature:1
                                                   
      @bz1888946                                                                                                                                                                                  
      Scenario: Global option 'proxy_username' is set but not 'proxy_password'  # features/microdnf/error_messages.feature:5
        Given I use repository "dnf-ci-fedora"                                  # features/steps/repo.py:138
        And I use repository "dnf-ci-fedora-updates"                            # features/steps/repo.py:138
        And I configure dnf with                                                # features/steps/config.py:12  
          | key            | value |                                                                                                                                                              
          | proxy_username | user  |                                                                                                                                                              
        When I execute microdnf with args "repoquery abcde"                     # features/steps/cmd.py:138                                                                                           Then the exit code is 1                                                 # common/output.py:33                                                                                                   Assertion Failed: Command has returned exit code 0: microdnf -y --installroot=/tmp/dnf_ci_installroot_wyxd9r4a --noplugins --config=/tmp/dnf_ci_installroot_wyxd9r4a/etc/dnf/dnf.conf --
    setopt=reposdir=/tmp/dnf_ci_installroot_wyxd9r4a/etc/yum.repos.d --setopt=varsdir=/tmp/dnf_ci_installroot_wyxd9r4a/etc/dnf/vars --setopt=cachedir=/tmp/dnf_ci_installroot_wyxd9r4a/var/cache/y
    um --releasever=29 --setopt=module_platform_id=platform:f29 repoquery abcde                                                                                                                                                                                                                                                                                                                 Last Command: microdnf -y --installroot=/tmp/dnf_ci_installroot_wyxd9r4a --noplugins --config=/tmp/dnf_ci_installroot_wyxd9r4a/etc/dnf/dnf.conf --setopt=reposdir=/tmp/dnf_ci_installroot_wyxd
    9r4a/etc/yum.repos.d --setopt=varsdir=/tmp/dnf_ci_installroot_wyxd9r4a/etc/dnf/vars --setopt=cachedir=/tmp/dnf_ci_installroot_wyxd9r4a/var/cache/yum --releasever=29 --setopt=module_platform_
    id=platform:f29 repoquery abcde
                                                   
    Last Command stdout:  
    abcde-2.9.2-1.fc29.noarch
    abcde-2.9.2-1.fc29.src
    abcde-2.9.3-1.fc29.noarch
    abcde-2.9.3-1.fc29.src


Expected results:
Tests should pass

Additional info:

Comment 15 errata-xmlrpc 2021-11-09 19:48:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (microdnf bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4441


Note You need to log in before you can comment on or make changes to this bug.