Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 1924079

Summary: GdmDisplay: Session never registered, failing
Product: Red Hat Enterprise Linux 8 Reporter: Michal Odehnal <modehnal>
Component: gdmAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED ERRATA QA Contact: Michal Odehnal <modehnal>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 8.4CC: apjagtap, hdegoede, nate.johnston, rstrode, tpelka, tpopela
Target Milestone: rcKeywords: Triaged
Target Release: 8.0Flags: pm-rhel: mirror+
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: gdm-40.0-26.el8 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2023-05-16 08:27:13 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Deadline: 2023-02-27   
Attachments:
Description Flags
fix for the issue none

Description Michal Odehnal 2021-02-02 14:48:44 UTC
Description of problem:
When doing start/stop of gdm the error pops up in the status log.

Version-Release number of selected component (if applicable):
gdm-3.28.3-38.el8
gdm-3.28.3-39.el8

How reproducible:
100%

Steps to Reproduce:
1. sudo systemctl start gdm
2. sudo systemctl stop gdm
3. sudo systemctl status gdm

Actual results:
Feb 02 09:43:08 beaker-gnome-terminal-develop-328 systemd[1]: Stopping GNOME Display Manager...
Feb 02 09:43:09 beaker-gnome-terminal-develop-328 gdm[91486]: GdmDisplay: Session never registered, failing
Feb 02 09:43:09 beaker-gnome-terminal-develop-328 gdm[91486]: GLib: g_hash_table_foreach: assertion 'version == hash_table->version' failed
Feb 02 09:43:09 beaker-gnome-terminal-develop-328 systemd[1]: gdm.service: Succeeded.
Feb 02 09:43:09 beaker-gnome-terminal-develop-328 systemd[1]: Stopped GNOME Display Manager.

Expected results:
Feb 02 09:43:09 beaker-gnome-terminal-develop-328 systemd[1]: Stopped GNOME Display Manager.

No extra error messages

Additional info:

Comment 4 Michal Odehnal 2021-10-18 15:19:57 UTC
It seems it was not fixed together with the 2004170, the 'Gdm: GdmDisplay: Session never registered, failing' is still there:

[test@zalman1-vm6-c-01 ~]$ date
Mon Oct 18 17:16:38 CEST 2021
[test@zalman1-vm6-c-01 ~]$ systemctl start gdm
[test@zalman1-vm6-c-01 ~]$ systemctl stop gdm
[test@zalman1-vm6-c-01 ~]$ systemctl status gdm
● gdm.service - GNOME Display Manager
   Loaded: loaded (/usr/lib/systemd/system/gdm.service; enabled; vendor preset: enabled)
   Active: inactive (dead) since Mon 2021-10-18 17:16:54 CEST; 3s ago
  Process: 86812 ExecStopPost=/usr/bin/bash -c for f in /run/systemd/sessions/*; do [ -f $f ] && /usr/bin/fgrep -q SERVICE=gdm $f && loginctl terminate-session $(basename $f); done (code=exited, status=0/SUCCES>
  Process: 86246 ExecStart=/usr/sbin/gdm (code=exited, status=0/SUCCESS)
 Main PID: 86246 (code=exited, status=0/SUCCESS)

Oct 18 17:16:47 zalman1-vm6-c-01.tpb.lab.eng.brq.redhat.com systemd[1]: Starting GNOME Display Manager...
Oct 18 17:16:47 zalman1-vm6-c-01.tpb.lab.eng.brq.redhat.com systemd[1]: Started GNOME Display Manager.
Oct 18 17:16:54 zalman1-vm6-c-01.tpb.lab.eng.brq.redhat.com systemd[1]: Stopping GNOME Display Manager...
Oct 18 17:16:54 zalman1-vm6-c-01.tpb.lab.eng.brq.redhat.com gdm[86246]: Gdm: GdmDisplay: Session never registered, failing
Oct 18 17:16:54 zalman1-vm6-c-01.tpb.lab.eng.brq.redhat.com systemd[1]: gdm.service: Succeeded.
Oct 18 17:16:54 zalman1-vm6-c-01.tpb.lab.eng.brq.redhat.com systemd[1]: Stopped GNOME Display Manager.

[test@zalman1-vm6-c-01 ~]$ rpm -q gdm
gdm-40.0-15.el8.x86_64

Comment 10 Ray Strode [halfline] 2022-12-12 16:21:41 UTC
Created attachment 1932117 [details]
fix for the issue

this should fix the warning issue. I think the hash table problem was fixed a while back already, IIRC.

Comment 11 Ray Strode [halfline] 2022-12-12 19:28:08 UTC
Setting ITM to the end of the non-exception period. Feel free to reign it in as required...

Comment 17 errata-xmlrpc 2023-05-16 08:27:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (gdm bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2023:2779