Bug 192438 - Review Request: fedora-xgl-settings
Review Request: fedora-xgl-settings
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Package Reviews List
:
: 192439 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-19 14:43 EDT by Alphonse Van Assche
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-21 16:59:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alphonse Van Assche 2006-05-19 14:43:34 EDT
Spec URL: http://users.telenet.be/quenta/SPECS/fedora-xgl-settings.spec
SRPM URL: http://users.telenet.be/quenta/repo/fedora-xgl-settings-0.0.1-1.src.rpm

Description:
At this time, a whole of bash script to configure xgl on fedora.

They are my first paquackages and I need a sponsor. 

regards,
Al
Comment 1 Alphonse Van Assche 2006-05-19 15:06:12 EDT
sorry I wanted to make the thing too quickly, the real package name is
fedora-xgl-settings
Comment 2 Jason Tibbitts 2006-05-24 14:28:33 EDT
*** Bug 192439 has been marked as a duplicate of this bug. ***
Comment 3 Chris Weyl 2006-06-15 21:01:11 EDT
Spec url seems to return a 404-not-found error?
Comment 4 Alphonse Van Assche 2006-06-20 18:01:40 EDT
SPEC URL:
http://fedoraxgl.tuxfamily.org/repository/5/SPECS/3ddesktop-configurator.spec
SRPM URL: http://fedoraxgl.tuxfamily.org/repository/5/SRPMS/3ddesktop-0.1-1.src.rpm

I have write a new software to replace fedora-xgl-settings.
It give the possiblity to configure AIXGL, XGL and Compiz on fedora core system.

- Can be to easily configure for other core/distrib/system, via a properties
file or by extending two abstract classes, if necessary.
- Check hardware compatibility for Aiglx and Xgl in XML files.
- Switch to default, aiglx, xgl X server. (fedora-3ddesktop-switch)
- Information about system configuration. (fedora-3ddesktop-info)
- A GUI that use the two above commands (fedora-3ddesktop-gui)

There is still much thing has to code but it work already well.

TODO:
- Find real hardware support data for aiglx.
- Find nice icons for System information status buttons.
- Give the possibility to add new DISPLAY configuration.
- Dedicated settings for each DISPLAY.
  
Thank's to the java-gnome team for this nice binding!

Comment 5 Thorsten Leemhuis 2006-07-04 08:58:55 EDT
Note: this package accidentally for assigned to me. That's wrong, I'm not
interested in it and won't do a review. This bug should be treated as it was in
a NEW state (it still blocks FE_NEW so most people will know that nobody is
reviewing this yet).
Comment 6 Rick L Vinyard Jr 2006-07-05 09:52:48 EDT
Just an operability comment...

I'm not sure how many others may be having trouble with these packages, but at
first I couldn't get gdm to start with Xgl.

The problem was that Xgl was taking too long to start and gdm was timing out.
The (simple) solution was to put the following line in /etc/gdm/custom.conf
after the [daemon] line:
    GdmXserverTimeout=60

Poking around on several Xgl and compiz lists it looks like this is a fairly
common issue.
Comment 7 Alphonse Van Assche 2006-07-06 05:41:04 EDT
(In reply to comment #6)

We can add the possibility of changing this property via the GUI of
3ddesktop-configurator.
But if the mofification of the default.conf file is made on the GDM package, I
think that it would not be necessary?
Comment 8 Stewart Adam 2006-09-17 22:02:45 EDT
rpmlint isn't silent on the SRPM:
W: 3ddesktop no-url-tag
E: 3ddesktop invalid-spec-name 3ddesktop-configurator.spec
Your spec filename must end with '.spec'. If it's not the case, rename your
file and rebuild your package.

W: 3ddesktop rpm-buildroot-usage %prep rm -rf $RPM_BUILD_ROOT
$RPM_BUILD_ROOT should not be touched during %build or %prep stage, as it
will break short circuiting.

E: 3ddesktop no-cleaning-of-buildroot
You should clean $RPM_BUILD_ROOT in the %clean section and just after the
beginning of %install section. Use "rm -Rf $RPM_BUILD_ROOT".

W: 3ddesktop mixed-use-of-spaces-and-tabs
The specfile mixes use of spaces and tabs for indentation, which is a
cosmetic annoyance.  Use either spaces or tabs for indentation, not both.
Comment 9 Stewart Adam 2006-09-17 23:06:00 EDT
Hello,
Sorry, I forgot to mention before that I'm not a Fedora reviewer, but I'm just
helping out.

I've tried building your RPM and it fails, but once I install these packages:
 (1) jakarta-oro (2) libgtk-java (3) libglade-java (4) libgconf-java 
It will build, but with warnings. I think those need to be on %buildrequries,
and if they're needed for running it too, then in regular %requires.
Comment 10 Stewart Adam 2006-09-18 17:48:49 EDT
I've done further testing, and noticed that in your pam files you're using the
old stack - Instead, have the PAM files read:
auth        include     config-util
account     include     config-util
session     include     config-util
Also, building a binary RPM complains about not finding a bunch of javadocs
APIs, and also then fails because it cannot replace a 'overview-frame.html' :
[javadoc] WARNING: Cannot locate class java.nio.CharBuffer referenced in class
org.fedora3ddesktop.cmdline.Utils
[ messages continue ]
[javadoc] WARNING: Cannot locate class org.gnu.gtk.event.ButtonEvent referenced
in class org.fedora3ddesktop.gui.DialogGdmDisplayManager
[ messages continue ]
[...]/BUILD/3ddesktop-0.1/build.xml:86: Replace: source file
[...]/BUILD/3ddesktop-0.1/docs/api/overview-frame.html doesn't existfile.

Maybe there are more %requires needed?

Also, fixing the no-cleaning-of-buildroot error is simple, all you have to to is
add:
rm -rf $RPM_BUILD_ROOT
to the very beginning of %install.
Comment 11 Stewart Adam 2006-09-18 18:35:21 EDT
It finally compiled on my FC6T3 system one I removed lines 85 and 86 in the
build.xml... The additional packages I needed to install are listed above.
rpmlint output on the binary RPMS:

W: 3ddesktop incoherent-version-in-changelog 0.1-1 0:0.1-1
Your last entry in %changelog contains a version that is not coherent with
the current version of your package.

W: 3ddesktop no-url-tag
E: 3ddesktop zero-length /usr/share/doc/3ddesktop-0.1/README
E: 3ddesktop zero-length /usr/share/doc/3ddesktop-0.1/ChangeLog
W: 3ddesktop class-path-in-manifest /usr/share/java/3ddesktop-gui-0.1.jar
The META-INF/MANIFEST file in the jar contains a hardcoded Class-Path.
These entries do not work with older Java versions and even if they do work,
they are inflexible and usually cause nasty surprises.

W: 3ddesktop class-path-in-manifest /usr/share/java/3ddesktop-info-0.1.jar
The META-INF/MANIFEST file in the jar contains a hardcoded Class-Path.
These entries do not work with older Java versions and even if they do work,
they are inflexible and usually cause nasty surprises.

W: 3ddesktop class-path-in-manifest /usr/share/java/3ddesktop-switch-0.1.jar
The META-INF/MANIFEST file in the jar contains a hardcoded Class-Path.
These entries do not work with older Java versions and even if they do work,
they are inflexible and usually cause nasty surprises.

W: 3ddesktop-javadoc non-standard-group Development/Java
The value of the Group tag in the package is not valid.  Valid groups are:
"Amusements/Games", "Amusements/Graphics", "Applications/Archiving",
"Applications/Communications", "Applications/Databases",
"Applications/Editors", "Applications/Emulators", "Applications/Engineering",
"Applications/File", "Applications/Internet", "Applications/Multimedia",
"Applications/Productivity", "Applications/Publishing", "Applications/System",
"Applications/Text", "Development/Debug", "Development/Debuggers",
"Development/Languages", "Development/Libraries", "Development/System",
"Development/Tools", "Documentation", "System Environment/Base", "System
Environment/Daemons", "System Environment/Kernel", "System
Environment/Libraries", "System Environment/Shells", "User
Interface/Desktops", "User Interface/X", "User Interface/X Hardware Support".

W: 3ddesktop-javadoc no-url-tag

If you need help cleaning those errors out, let me know - I'll help modify the
spec file
Comment 13 Jonathan Steffan 2007-06-09 16:00:10 EDT
We should really close this bug as fedora-xgl-settings is no longer being worked
on in preference to a better configuration solution. Please comment Alphonse.
Comment 14 Jason Tibbitts 2007-06-21 16:31:24 EDT
It's been almost a year since the last response from the author.  I will close
this ticket if there is no response soon.
Comment 15 Alphonse Van Assche 2007-06-21 16:59:40 EDT
oups I have forgot this, sorry Jonathan... yes we may close it.

Note You need to log in before you can comment on or make changes to this bug.