Bug 19245 - New gnorpm-0.95 core dumps when CD-ROM is mounted
Summary: New gnorpm-0.95 core dumps when CD-ROM is mounted
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnorpm (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Dale Lovelace
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-17 12:31 UTC by Diego Novillo
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-27 15:38:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Diego Novillo 2000-10-17 12:31:45 UTC
I upgraded gnorpm to 0.95-1 (the one posted to the RHN on Oct10) and
started having problems with the Install button. If there is a CD mounted,
pushing the Install button will cause the program to coredump.

I had to downgrade the program to the version that came in the 7.0 CD.

Comment 1 Alan Cox 2000-10-17 15:49:46 UTC
Its rather broken yes. Ive sent msw the patches to do a working errata fix
instead. You can also find my (maintainer official rather than RH official) rpms
for 7.0 on ftp.linux.org.uk/pub/linux/alan/GNORPM. Feedback on these test rpms
welcomed


Comment 2 Jeff Norden 2000-10-19 23:06:27 UTC
I just installed Alan's gnorpm-0.95.1-4 from ftp.linux.org.uk, and it works fine
for me.  (I had also downgraded to the original 7.0 gnorpm in order to be able
to actually use it).  Thanks!


Comment 3 Need Real Name 2000-10-23 12:02:24 UTC
I was having similar problems and they were fixed when I upgraded to
gnorpm-0.95.1-4 also!  what was the cause of this error btw?

Comment 4 Alan Cox 2000-10-27 15:38:55 UTC
The problem was incorrect options in a header file causing a bad build. How it
got past QA I dont know. Thats something we have to figure out internally. 


Comment 5 Jeff Johnson 2000-10-30 18:33:39 UTC
Fixed in gnorpm-0.95.1-5 errata.


Note You need to log in before you can comment on or make changes to this bug.