Bug 1925233 - Secondary ports of masters and workers created differently
Summary: Secondary ports of masters and workers created differently
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.7
Hardware: All
OS: All
medium
low
Target Milestone: ---
: 4.8.0
Assignee: Adolfo Duarte
QA Contact: Jon Uriarte
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-02-04 16:20 UTC by Michał Dulko
Modified: 2021-04-14 15:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-14 15:07:36 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Michał Dulko 2021-02-04 16:20:45 UTC
Version: 

That's a 4.7 nightly.

Platform:

openstack

Please specify:
* IPI

What happened?

There's an inconsistency in how secondary network ports are created for masters and workers. For workers the ports on secondary network will be tagged and have a trunk created. For masters none of those will happen.

What did you expect to happen?

I'd expect consistent behavior here. I don't have a strong opinion on tagging but I do on trunk ports - trunks are only created for Kuryr to function correctly, so they're not necessary on secondary interfaces.

How to reproduce it (as minimally and precisely as possible)?

1. Run installation with additionalNetworkIDs for masters and workers.
2. Inspect ports of masters and workers created for additional networks.

Anything else we need to know?

https://bugzilla.redhat.com/show_bug.cgi?id=1924917 - that happens due to this behavior. We'll work it around in Kuryr anyway.


Note You need to log in before you can comment on or make changes to this bug.