Bug 1925415 - [e2e][automation] Improve tests by wait for importing complete
Summary: [e2e][automation] Improve tests by wait for importing complete
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.7
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.7.0
Assignee: Tomas Jelinek
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-02-05 07:10 UTC by Guohua Ouyang
Modified: 2021-02-08 09:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-08 09:44:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 8065 0 None open Bug 1925415: waiting for VM importing before move on 2021-02-05 07:13:17 UTC

Description Guohua Ouyang 2021-02-05 07:10:03 UTC
Description of problem:
Some tests are failed because importing is not finished yet, so start the VM is blocking by confirm dialog. Fix below tests:

 KubeVirt VM scheduling.VM is scheduled on labelled node	3 min 58 sec	2
 KubeVirt VM scheduling.VM can be scheduling to node with affinity rules	3.5 sec	2
 KubeVirt VM scheduling.VM has no tolerations can only be scheduling to untainted node	2.3 sec	2
 KubeVirt VM scheduling.VM can be scheduling to tainted node with matched tolerations	3.5 sec	2
 Add/remove disks and NICs on respective VM pages.Add/remove disk on VM disks page	4 min 1 sec	2
 Add/remove disks and NICs on respective VM pages.Add/remove nic on VM Network Interfaces page	1.5 sec	2
 Add/remove disks and NICs on respective VM pages.NIC can be added twice using one net-attach-def	1.5 sec	2

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:


Note You need to log in before you can comment on or make changes to this bug.