Bug 192558 - Enhancement for encrypted swap missing, patch attached
Enhancement for encrypted swap missing, patch attached
Status: CLOSED DUPLICATE of bug 127378
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
5
All Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-20 12:35 EDT by Peter Bieringer
Modified: 2014-03-16 22:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-25 11:03:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch against current rc.sysinit to support encrypted swap drives (1.33 KB, patch)
2006-05-20 12:35 EDT, Peter Bieringer
no flags Details | Diff

  None (edit)
Description Peter Bieringer 2006-05-20 12:35:18 EDT
Description of problem:
FC5 currenty misses support for encrypted swap partitions

Version-Release number of selected component (if applicable):
initscripts-8.31.1-1

Additional info:

Attached you will find a simple but very useful patch to enhance
/etc/rc.d/rc.sysinit to support encrypted swap partitions.

After applying the patch, following entry in /etc/fstab will result in setup of
encrypted swap:

LABEL=SWAPENC-sda2      swap-encrypted          swap   
dev=/dev/sda2,cipher=blowfish       0 0


BTW: rc.sysinit also misses support of encrypted partitions at all, I have also
a first patch for this, but this need some regressions before publishing.
Comment 1 Peter Bieringer 2006-05-20 12:35:18 EDT
Created attachment 129760 [details]
Patch against current rc.sysinit to support encrypted swap drives
Comment 2 Miloslav Trmač 2006-05-25 11:03:41 EDT

*** This bug has been marked as a duplicate of 127378 ***

Note You need to log in before you can comment on or make changes to this bug.