Bug 192559 - policycoreutils misses 1.30.8-1.fc5 dependency rhlp
policycoreutils misses 1.30.8-1.fc5 dependency rhlp
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2006-05-20 14:51 EDT by Peter Bieringer
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-03-28 16:01:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2006-05-20 14:51:24 EDT
Following happen afer a "yum upgrade" on a system, which hasn't rhpl installed:

 Package                 Arch       Version          Repository        Size
 glibc                   i686       2.4-8            updates           4.9 M
 glibc-common            i386       2.4-8            updates            16 M
 nscd                    i386       2.4-8            updates           139 k
 ntp                     i386       4.2.0.a.20050816-11.FC5  updates
1.2 M
 policycoreutils         i386       1.30.8-1.fc5     updates           275 k
 psmisc                  i386       22.2-1.1         updates            62 k
 selinux-policy          noarch     2.2.38-1.fc5     updates           468 k
 selinux-policy-targeted  noarch     2.2.38-1.fc5     updates           461 k

Transaction Summary

  Updating  : selinux-policy-targeted      ####################### [ 8/16]
Traceback (most recent call last):
  File "/usr/sbin/genhomedircon", line 29, in ?
    from rhpl.translate import _, N_
ImportError: No module named rhpl.translate
libsemanage.semanage_install_sandbox: genhomedircon returned error code 1.

Additional info:
rhpl was removed previously because of no dependency and no use.
BTW: why need rhpl "wireless-tools"?

After installing rhpl and run a reinstall (-U --force), error wouldn't occur again.
Comment 1 Daniel Walsh 2006-05-23 23:38:28 EDT
policycoreutils requires it for translations code.

fixed in policycoreutils-1.30.10-1.fc5
Comment 2 Daniel Walsh 2007-03-28 16:01:17 EDT
Closing bugs

Note You need to log in before you can comment on or make changes to this bug.