Bug 192561 - memtest86+ fails to build in mock
memtest86+ fails to build in mock
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks: BuildReqBlocker
  Show dependency treegraph
 
Reported: 2006-05-20 15:32 EDT by Michael J Knox
Modified: 2013-01-09 22:48 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-08 15:21:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Matt Domsch's root.log (9.14 KB, text/plain)
2006-05-20 15:32 EDT, Michael J Knox
no flags Details

  None (edit)
Description Michael J Knox 2006-05-20 15:32:12 EDT
This package fails to build in mock. root.log attached

mock debug message:

Executing /usr/sbin/mock-helper yum --installroot
/var/lib/mock/fedora-development-x86_64-core-memtest86+-1.65-2.2.src.rpm/root
resolvedep  '/usr/include/gnu/stubs-32.h'
No Package Found for /usr/include/gnu/stubs-32.h
Cleaning up...
Comment 1 Michael J Knox 2006-05-20 15:32:12 EDT
Created attachment 129764 [details]
Matt Domsch's root.log
Comment 2 Warren Togami 2006-05-20 19:02:28 EDT
memtest86+ x86_64 is actually trying to build the i386 binaries, which is not
provided in the mock buildroot.  I think it is broken that we are building
x86_64 RPMS of this rather than simply reusing the i386 RPM on x86_64.  Can't we
fix this with the install tree build instead?
Comment 3 Warren Togami 2006-05-21 19:45:20 EDT
Reassigning to installer team.  Removing upstream from CC because this is not
their problem.
Comment 4 Jeremy Katz 2006-05-22 13:06:29 EDT
No, we just need to ensure we can build things which require 32-bit glibc on
x86_64.  Otherwise, we have to add special cases to the compose tools
Comment 5 Jesse Keating 2006-06-08 15:21:44 EDT
BR on a 32bit file was aded, brew can build this package.  Just need 32bit glibc
allowed in the buildroot.

Note You need to log in before you can comment on or make changes to this bug.