Bug 1926071 - datagrepper fails to build with Python 3.10: ImportError: cannot import name 'Iterable' from 'collections'
Summary: datagrepper fails to build with Python 3.10: ImportError: cannot import name ...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: datagrepper
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fedora Infrastructure SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1968793 (view as bug list)
Depends On: 1926112
Blocks: F35FTBFS F35FailsToInstall PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-02-08 07:27 UTC by Tomáš Hrnčiar
Modified: 2021-06-19 19:52 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-19 19:52:43 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-02-08 07:27:04 UTC
datagrepper fails to build with Python 3.10.0a5.

======================================================================
ERROR: Failure: ImportError (cannot import name 'Iterable' from 'collections' (/usr/lib64/python3.10/collections/__init__.py))
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib/python3.10/site-packages/nose/failure.py", line 39, in runTest
    raise self.exc_val.with_traceback(self.tb)
  File "/usr/lib/python3.10/site-packages/nose/loader.py", line 416, in loadTestsFromName
    module = self.importer.importFromPath(
  File "/usr/lib/python3.10/site-packages/nose/importer.py", line 47, in importFromPath
    return self.importFromDir(dir_path, fqname)
  File "/usr/lib/python3.10/site-packages/nose/importer.py", line 94, in importFromDir
    mod = load_module(part_fqname, fh, filename, desc)
  File "/usr/lib64/python3.10/imp.py", line 234, in load_module
    return load_source(name, filename, file)
  File "/usr/lib64/python3.10/imp.py", line 171, in load_source
    module = _load(spec)
  File "<frozen importlib._bootstrap>", line 729, in _load
  File "<frozen importlib._bootstrap>", line 698, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 833, in exec_module
  File "<frozen importlib._bootstrap>", line 241, in _call_with_frames_removed
  File "/builddir/build/BUILD/datagrepper-0.9.7/tests/test_api.py", line 10, in <module>
    import datagrepper.app
  File "/builddir/build/BUILD/datagrepper-0.9.7/datagrepper/app.py", line 31, in <module>
    import pygal
  File "/usr/lib/python3.10/site-packages/pygal/__init__.py", line 33, in <module>
    from pygal.graph.bar import Bar
  File "/usr/lib/python3.10/site-packages/pygal/graph/bar.py", line 27, in <module>
    from pygal.graph.graph import Graph
  File "/usr/lib/python3.10/site-packages/pygal/graph/graph.py", line 26, in <module>
    from pygal._compat import is_list_like, is_str, to_str
  File "/usr/lib/python3.10/site-packages/pygal/_compat.py", line 23, in <module>
    from collections import Iterable
ImportError: cannot import name 'Iterable' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)

======================================================================
ERROR: Failure: ImportError (cannot import name 'Iterable' from 'collections' (/usr/lib64/python3.10/collections/__init__.py))
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib/python3.10/site-packages/nose/failure.py", line 39, in runTest
    raise self.exc_val.with_traceback(self.tb)
  File "/usr/lib/python3.10/site-packages/nose/loader.py", line 416, in loadTestsFromName
    module = self.importer.importFromPath(
  File "/usr/lib/python3.10/site-packages/nose/importer.py", line 47, in importFromPath
    return self.importFromDir(dir_path, fqname)
  File "/usr/lib/python3.10/site-packages/nose/importer.py", line 94, in importFromDir
    mod = load_module(part_fqname, fh, filename, desc)
  File "/usr/lib64/python3.10/imp.py", line 234, in load_module
    return load_source(name, filename, file)
  File "/usr/lib64/python3.10/imp.py", line 171, in load_source
    module = _load(spec)
  File "<frozen importlib._bootstrap>", line 729, in _load
  File "<frozen importlib._bootstrap>", line 698, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 833, in exec_module
  File "<frozen importlib._bootstrap>", line 241, in _call_with_frames_removed
  File "/builddir/build/BUILD/datagrepper-0.9.7/tests/test_cors.py", line 9, in <module>
    import datagrepper.app
  File "/builddir/build/BUILD/datagrepper-0.9.7/datagrepper/app.py", line 31, in <module>
    import pygal
  File "/usr/lib/python3.10/site-packages/pygal/__init__.py", line 33, in <module>
    from pygal.graph.bar import Bar
  File "/usr/lib/python3.10/site-packages/pygal/graph/bar.py", line 27, in <module>
    from pygal.graph.graph import Graph
  File "/usr/lib/python3.10/site-packages/pygal/graph/graph.py", line 26, in <module>
    from pygal._compat import is_list_like, is_str, to_str
  File "/usr/lib/python3.10/site-packages/pygal/_compat.py", line 23, in <module>
    from collections import Iterable
ImportError: cannot import name 'Iterable' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)

----------------------------------------------------------------------
Ran 10 tests in 0.459s

FAILED (errors=2)
Test failed: <unittest.runner.TextTestResult run=10 errors=2 failures=0>

bpo-37324: Remove deprecated aliases to Collections Abstract Base Classes
from the collections module.

https://docs.python.org/3.10/whatsnew/changelog.html#python-3-10-0-alpha-5

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01951910-datagrepper/

For all our attempts to build datagrepper with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/datagrepper/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Ben Cotton 2021-02-09 16:05:30 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 2 Karthikeyan Singaravelan 2021-02-17 15:45:31 UTC
Fixed in pygal in https://github.com/Kozea/pygal/commit/7796f14c80fe82b9435cdc33b7d2939c8331d649

Comment 3 Miro Hrončok 2021-06-04 20:14:16 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 4 Miro Hrončok 2021-06-07 22:58:55 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 5 Miro Hrončok 2021-06-08 11:14:15 UTC
*** Bug 1968793 has been marked as a duplicate of this bug. ***

Comment 6 Miro Hrončok 2021-06-15 20:24:10 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 7 Kevin Fenzi 2021-06-19 19:52:43 UTC
Built now in rawhide.


Note You need to log in before you can comment on or make changes to this bug.