Bug 1926212 - python-grako fails to build with Python 3.10: ImportError: cannot import name 'Mapping' from 'collections'
Summary: python-grako fails to build with Python 3.10: ImportError: cannot import name...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-grako
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Eric Smith
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1968995 (view as bug list)
Depends On:
Blocks: F35FTBFS F35FailsToInstall PYTHON3.10 1927312
TreeView+ depends on / blocked
 
Reported: 2021-02-08 13:06 UTC by Tomáš Hrnčiar
Modified: 2021-07-08 07:36 UTC (History)
4 users (show)

Fixed In Version: python-grako-3.99.9-1.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-08 07:36:07 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-02-08 13:06:21 UTC
python-grako fails to build with Python 3.10.0a5.

Traceback (most recent call last):
  File "/builddir/build/BUILD/grako-3.18.1/setup.py", line 5, in <module>
    import grako
  File "/builddir/build/BUILD/grako-3.18.1/grako/__init__.py", line 5, in <module>
    from grako.tool import gencode, genmodel, main  # noqa
  File "/builddir/build/BUILD/grako-3.18.1/grako/tool.py", line 15, in <module>
    from grako.parser import GrakoGrammarGenerator
  File "/builddir/build/BUILD/grako-3.18.1/grako/parser.py", line 19, in <module>
    from grako.grammars import GrakoContext
  File "/builddir/build/BUILD/grako-3.18.1/grako/grammars.py", line 16, in <module>
    from collections import defaultdict, Mapping
ImportError: cannot import name 'Mapping' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)
bpo-37324: Remove deprecated aliases to Collections Abstract Base Classes
from the collections module.

https://docs.python.org/3.10/whatsnew/changelog.html#python-3-10-0-alpha-5

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01952242-python-grako/

For all our attempts to build python-grako with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-grako/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Ben Cotton 2021-02-09 16:06:55 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 2 Miro Hrončok 2021-06-04 20:13:07 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 3 Miro Hrončok 2021-06-07 22:58:01 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 4 Miro Hrončok 2021-06-08 11:26:01 UTC
*** Bug 1968995 has been marked as a duplicate of this bug. ***

Comment 5 Miro Hrončok 2021-06-15 20:24:46 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 6 Miro Hrončok 2021-07-07 11:21:07 UTC
Hello,

This is the second reminder (step 4 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 7 David King 2021-07-08 07:36:07 UTC
I applied the bare-minimum patches to make the latest (and final) grako release build with Python 3.10.


Note You need to log in before you can comment on or make changes to this bug.