Bug 192623 - changed md5sum of pnmdepth binary
changed md5sum of pnmdepth binary
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: netpbm (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-21 18:24 EDT by Christian Krause
Modified: 2013-07-02 19:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-21 06:51:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Krause 2006-05-21 18:24:28 EDT
Description of problem:

I've checked the integrity of my system using rpm -V and there was a problem
with the pnmdepth binary:

Package netpbm-progs-10.33-1.fc5:
SM5....T.   /usr/bin/pnmdepth



Version-Release number of selected component (if applicable):
FC5, netpbm-progs-10.33-1.fc5

How reproducible:
Unknown - I don't know, after which update the problem occured.
Please note that his problem occured on all of my FC5 machines, so that a hard
disc error cannot be the source of this problem

After I removed the package and re-installed it, the binary is correct.
Comment 1 Christian Krause 2006-05-24 22:53:53 EDT
Update:

It seems, that this file was changed again - again on several hosts. So there
must be some entity which alters this file sometimes. If a script or a cronjob
does changes in a binary file then this problem should be taken seriously. ;-)
Comment 2 Jindrich Novy 2006-05-24 23:53:49 EDT
There was a bug in netpbm-10.32 such that it contained dangling symlink
affecting pnmdepth because of a typo in the upstream Makefile. The pnmdepth
utility was replaced by a symlink to pamdepth correctly since 10.33. The only
thing that I can guess from the top of my head is that for some reason you have
installed both 10.32 and 10.33 netpbms on your system that conflict -> might
make rpm -V fail. What does rpm -q netpbm say?
Comment 3 Christian Krause 2006-05-25 10:37:39 EDT
No, there is only one package installed:

root@:~# rpm -q netpbm
netpbm-10.33-1.fc5
root@:~# 

Where can I get the previous version of netpbm-progs to compare the binaries of
the pnmdepth program (I've saved the file with the wrong md5 sum)?
Comment 4 Christian Krause 2006-05-25 17:07:07 EDT
I've found an explanation for this problem:
prelink changes the link to a regular file
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=193175

Because I'm not sure whether this is a problem of prelink or netpbm-progs, I'll
wait for some response from the prelink people until I'll close this bug.
Comment 5 Jindrich Novy 2006-09-21 06:51:26 EDT
Ok, closing this one as I don't see any rpm -V problems any more with the
current rawhide netpbm-progs.

Note You need to log in before you can comment on or make changes to this bug.