Bug 1926233 - python-svg-path fails to build with Python 3.10: ImportError: cannot import name 'MutableSequence' from 'collections'
Summary: python-svg-path fails to build with Python 3.10: ImportError: cannot import n...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-svg-path
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fedora Infrastructure SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1969149 (view as bug list)
Depends On:
Blocks: F35FTBFS F35FailsToInstall PYTHON3.10 1905407 1968802 1969065 1969066
TreeView+ depends on / blocked
 
Reported: 2021-02-08 13:23 UTC by Tomáš Hrnčiar
Modified: 2021-06-19 16:17 UTC (History)
7 users (show)

Fixed In Version: python-svg-path-4.1-1.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-19 16:17:07 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-02-08 13:23:39 UTC
python-svg-path fails to build with Python 3.10.0a5.

======================================================================
ERROR: path (unittest.loader._FailedTest)
----------------------------------------------------------------------
ImportError: Failed to import test module: path
Traceback (most recent call last):
  File "/usr/lib64/python3.10/unittest/loader.py", line 154, in loadTestsFromName
    module = __import__(module_name)
  File "/builddir/build/BUILD/svg.path-2.2/src/svg/path/__init__.py", line 1, in <module>
    from .path import Path, Line, Arc, CubicBezier, QuadraticBezier
  File "/builddir/build/BUILD/svg.path-2.2/src/svg/path/path.py", line 3, in <module>
    from collections import MutableSequence
ImportError: cannot import name 'MutableSequence' from 'collections' (/usr/lib64/python3.10/collections/__init__.py)


----------------------------------------------------------------------
Ran 1 test in 0.000s

FAILED (errors=1)
Test failed: <unittest.runner.TextTestResult run=1 errors=1 failures=0>

bpo-37324: Remove deprecated aliases to Collections Abstract Base Classes
from the collections module.

https://docs.python.org/3.10/whatsnew/changelog.html#python-3-10-0-alpha-5

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01952492-python-svg-path/

For all our attempts to build python-svg-path with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-svg-path/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Ben Cotton 2021-02-09 16:07:24 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 2 Miro Hrončok 2021-06-04 20:15:44 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 3 Miro Hrončok 2021-06-07 23:00:06 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 4 Miro Hrončok 2021-06-08 11:34:09 UTC
*** Bug 1969149 has been marked as a duplicate of this bug. ***

Comment 5 Damian Wrobel 2021-06-08 12:26:20 UTC
(In reply to Tomáš Hrnčiar from comment #0)
>     from collections import MutableSequence
> ImportError: cannot import name 'MutableSequence' from 'collections'
> (/usr/lib64/python3.10/collections/__init__.py)

Very likely it's fixed upstream[1]:

Changelog
4.1 (2021-02-16)
    Use collections.abc for ABC import to add Python 3.9 compatibility.


[1] https://pypi.org/project/svg.path/

Comment 6 Miro Hrončok 2021-06-15 20:25:00 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 7 Ankur Sinha (FranciscoD) 2021-06-17 19:07:22 UTC
PR opened: https://src.fedoraproject.org/rpms/python-svg-path/pull-request/2


Note You need to log in before you can comment on or make changes to this bug.