Bug 192625 - Mailman archiver wrongly removes multipart/mixed message parts
Mailman archiver wrongly removes multipart/mixed message parts
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mailman (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-21 18:45 EDT by Todd Zullinger
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-06 00:24:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backported patch (727 bytes, patch)
2006-05-21 18:45 EDT, Todd Zullinger
no flags Details | Diff

  None (edit)
Description Todd Zullinger 2006-05-21 18:45:27 EDT
Description of problem:
Mailman's archiver will wrongly remove (scrub) mime message parts with a content
type of multipart/mixed.  This includes any PGP/MIME signed message with an
attachment.  As this is a convenient (and somewhat common) way to send digitally
signed patch files to project mailing lists it is desireable to not lose the
attached patch in the mailing list archives.

See the following thread on the mailman-users list for a problem report and
resolution:

    http://www.mail-archive.com/mailman-users@python.org/msg38837.html

This bug has been fixed upstream since version 2.1.6.  The attached patch was
kindly backported from mailman's subversion repository by mailman developer Mark
Sapiro.

Version-Release number of selected component (if applicable):
mailman-2.1.5-35.fc4

How reproducible:
Always

Steps to Reproduce:
1. Send a message with a multipart/mixed content type part to a mailman list
2. Check the archives for the list
3. Notice that the message and attachment have been scrubbed
4. Resolve problem with help of mailman developer Mark Sapiro
5. File bug report here so others can benefit from solution
  
Actual results:
Message in archive is missing the message body and attachment.

Expected results:
Message body and attachment should be in the list archive.

Additional info:
The simplest way to generate a message which tickles this bug is a PGP/MIME
signed message with an attachment.  I used mutt to generate test messages, but
any PGP/MIME compliant MUA's messages ought to trigger the same problem in the
mailman archiver.
Comment 1 Todd Zullinger 2006-05-21 18:45:27 EDT
Created attachment 129787 [details]
Backported patch
Comment 3 Todd Zullinger 2006-05-22 16:09:03 EDT
Yes, the update to 2.1.8 does solve this issue.  I didn't do a lot of other
testing on the update, but it does install without issue and basic mailman
functionality is still working.  If I notice any problems I'll be sure to report
them.

Thanks Harald.
Comment 4 Todd Zullinger 2006-12-06 00:24:46 EST
The update to 2.1.8 didn't make it into FC4 before it was moved to Fedora
Legacy, but FL did release it.  Anyone using FL will have the fix as will users
of newer FC versions.  I'm marking this as Closed NEXTRELEASE to remove cruft
from bugzilla.  Hope that's OK.

Note You need to log in before you can comment on or make changes to this bug.