Bug 1926362 - python-odml fails to build with Python 3.10: AttributeError: module 'collections' has no attribute 'Iterable'
Summary: python-odml fails to build with Python 3.10: AttributeError: module 'collecti...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: python-odml
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Aniket Pradhan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1969063 (view as bug list)
Depends On:
Blocks: F35FTBFS F35FailsToInstall PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-02-08 17:12 UTC by Miro Hrončok
Modified: 2021-06-18 15:04 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-18 15:04:21 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2021-02-08 17:12:50 UTC
python-odml fails to build with Python 3.10.0a5.

___________________________ TestSection.test_extend ____________________________
self = <test.test_section.TestSection testMethod=test_extend>
    def test_extend(self):
        sec = Section(name="main")
        self.assertListEqual(sec.sections, [])
        self.assertListEqual(sec.properties, [])
    
        # Test extend with Section list
>       sec.extend([Section(name="sec1"), Section(name="sec2")])
test/test_section.py:407: 
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 
self = Section[0|0] {name = main, type = None, id = 2f6c6c85-8940-4437-871f-db1bc1cfd15d}
obj_list = [Section[0|0] {name = sec1, type = None, id = b725c9fa-ad6d-4002-9bc6-d7950c7ac534}, Section[0|0] {name = sec2, type = None, id = 61e99c5a-f6ba-4b50-ab11-1b33fac012a0}]
    def extend(self, obj_list):
        """
        Method adds Sections and Properties to the respective child-lists
        of the current Section.
    
        :param obj_list: Iterable containing Section and Property entries.
        """
>       if not isinstance(obj_list, collections.Iterable):
E       AttributeError: module 'collections' has no attribute 'Iterable'
odml/section.py:339: AttributeError


The deprecated aliases to Collections Abstract Base Classes were removed from the collections module.
https://docs.python.org/3.10/whatsnew/changelog.html#python-3-10-0-alpha-5
https://bugs.python.org/issue37324

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01952356-python-odml/

For all our attempts to build python-odml with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-odml/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Ben Cotton 2021-02-09 16:08:06 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 2 Miro Hrončok 2021-06-04 20:13:38 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 3 Miro Hrončok 2021-06-07 22:58:24 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 4 Miro Hrončok 2021-06-08 11:29:37 UTC
*** Bug 1969063 has been marked as a duplicate of this bug. ***

Comment 5 Miro Hrončok 2021-06-15 20:25:15 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 6 Miro Hrončok 2021-06-18 15:04:21 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok@redhat.com).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 35.

Thanks for taking care of it!


Note You need to log in before you can comment on or make changes to this bug.