Bug 1926373 - systemd-oomd.service: Failed to determine user credentials: No such process
Summary: systemd-oomd.service: Failed to determine user credentials: No such process
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anita Zhang
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: openqa
Depends On:
Blocks: F34FinalBlocker 1913794
TreeView+ depends on / blocked
 
Reported: 2021-02-08 18:03 UTC by Chris Murphy
Modified: 2021-02-16 19:16 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-16 19:16:24 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
journal (730.81 KB, text/plain)
2021-02-08 18:05 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2021-02-08 18:03:20 UTC
Description of problem:

systemd-oomd is failing in openqa testing during startup

fedora-Rawhide-Workstation-live-iso-x86_64-BuildFedora-Rawhide-20210208.n.0-base_services_start@64bit 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Boot the Workstation Live image from 20210208
https://kojipkgs.fedoraproject.org/compose/rawhide/Fedora-Rawhide-20210208.n.0/compose/Workstation/x86_64/iso/Fedora-Workstation-Live-x86_64-Rawhide-20210208.n.0.iso
2.
3.

Actual results:

[   14.000576] fedora systemd[562]: systemd-oomd.service: Failed to determine user credentials: No such process
[   14.001522] fedora systemd[562]: systemd-oomd.service: Failed at step USER spawning /usr/lib/systemd/systemd-oomd: No such process
[   14.015743] fedora systemd[1]: systemd-oomd.service: Main process exited, code=exited, status=217/USER
[   14.016012] fedora systemd[1]: systemd-oomd.service: Failed with result 'exit-code'.
[   14.017820] fedora systemd[1]: Failed to start Userspace Out-Of-Memory (OOM) Killer.



Expected results:

It should startup

Additional info:


https://openqa.fedoraproject.org/tests/772018

Comment 1 Chris Murphy 2021-02-08 18:05:13 UTC
Created attachment 1755771 [details]
journal

from the openqa instance logs, journalctl -o short-monotonic

Comment 2 Chris Murphy 2021-02-08 18:22:27 UTC
glibc-2.32.9000-29.fc34.x86_64 
systemd-247.3-1.fc34.x86_64

More package versions for this compose at:
https://kojipkgs.fedoraproject.org//work/tasks/7773/61577773/anaconda-packaging.log

Comment 3 Anita Zhang 2021-02-08 19:55:25 UTC
I put up https://src.fedoraproject.org/rpms/systemd/pull-request/49 to fix this. I haven't tested it out with a fresh install but the systemd-oom user appears to be missing from the image.

Comment 4 Ben Cotton 2021-02-09 16:08:11 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 5 Adam Williamson 2021-02-12 00:14:49 UTC
This should be a Final blocker, per "All system services present after installation with one of the release-blocking package sets must start properly, unless they require hardware which is not present" - https://fedoraproject.org/wiki/Fedora_34_Final_Release_Criteria#System_services . It also happens on KDE live installs, for the record.

Comment 6 Zbigniew Jędrzejewski-Szmek 2021-02-13 14:40:38 UTC
*** Bug 1927148 has been marked as a duplicate of this bug. ***

Comment 7 Michel Lind 2021-02-16 19:16:24 UTC
Fixed in 247.3-2 built for Rawhide and F34


Note You need to log in before you can comment on or make changes to this bug.