Bug 1926616 - python-compreffor fails to build with Python 3.10: AttributeError: module 'collections' has no attribute 'MutableMapping'
Summary: python-compreffor fails to build with Python 3.10: AttributeError: module 'co...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-compreffor
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ben Beasley
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1968936 (view as bug list)
Depends On:
Blocks: F35FTBFS F35FailsToInstall PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-02-09 08:23 UTC by Tomáš Hrnčiar
Modified: 2021-08-18 01:16 UTC (History)
4 users (show)

Fixed In Version: python-compreffor-0.5.1-1.fc35 python-compreffor-0.5.1-1.fc34 python-compreffor-0.5.1-1.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-08 23:38:32 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-02-09 08:23:37 UTC
python-compreffor fails to build with Python 3.10.0a5.

==================================== ERRORS ====================================
_____________ ERROR collecting src/python/compreffor/test/dummy.py _____________
src/python/compreffor/test/dummy.py:18: in <module>
    class DummyGlyphSet(collections.MutableMapping):
E   AttributeError: module 'collections' has no attribute 'MutableMapping'
_______ ERROR collecting src/python/compreffor/test/pyCompressor_test.py _______
src/python/compreffor/test/pyCompressor_test.py:19: in <module>
    from compreffor.test.dummy import DummyGlyphSet
src/python/compreffor/test/dummy.py:18: in <module>
    class DummyGlyphSet(collections.MutableMapping):
E   AttributeError: module 'collections' has no attribute 'MutableMapping'
_______ ERROR collecting src/python/compreffor/test/pyCompressor_test.py _______
src/python/compreffor/test/pyCompressor_test.py:19: in <module>
    from compreffor.test.dummy import DummyGlyphSet
src/python/compreffor/test/dummy.py:18: in <module>
    class DummyGlyphSet(collections.MutableMapping):
E   AttributeError: module 'collections' has no attribute 'MutableMapping'
=============================== warnings summary ===============================
../../../../usr/lib/python3.10/site-packages/fontTools/misc/py23.py:11
  /usr/lib/python3.10/site-packages/fontTools/misc/py23.py:11: DeprecationWarning: The py23 module has been deprecated and will be removed in the next release. Please update your code.
    warnings.warn(

-- Docs: https://docs.pytest.org/en/stable/warnings.html
=========================== short test summary info ============================
ERROR src/python/compreffor/test/dummy.py - AttributeError: module 'collectio...
ERROR src/python/compreffor/test/pyCompressor_test.py - AttributeError: modul...
ERROR src/python/compreffor/test/pyCompressor_test.py - AttributeError: modul...
!!!!!!!!!!!!!!!!!!! Interrupted: 3 errors during collection !!!!!!!!!!!!!!!!!!!!
========================= 1 warning, 3 errors in 0.15s =========================

The deprecated aliases to Collections Abstract Base Classes were removed from the collections module.
https://docs.python.org/3.10/whatsnew/changelog.html#python-3-10-0-alpha-5
https://bugs.python.org/issue37324

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01952155-python-compreffor/

For all our attempts to build python-compreffor with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-compreffor/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Ben Cotton 2021-02-09 16:08:51 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 2 Miro Hrončok 2021-06-04 20:12:50 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 3 Miro Hrončok 2021-06-07 22:57:48 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 4 Miro Hrončok 2021-06-08 11:22:48 UTC
*** Bug 1968936 has been marked as a duplicate of this bug. ***

Comment 5 Miro Hrončok 2021-06-15 20:25:32 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 6 Miro Hrončok 2021-07-07 11:22:35 UTC
Hello,

This is the second reminder (step 4 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 7 Fedora Release Engineering 2021-07-11 04:22:33 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 35.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2021-04-06).

A week before the mass branching of Fedora 36 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 34 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-36/f-36-key-tasks.html

Comment 8 Fedora Release Engineering 2021-08-01 04:22:41 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 35.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2021-04-06).

A week before the mass branching of Fedora 36 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 34 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-36/f-36-key-tasks.html

Comment 9 Miro Hrončok 2021-08-05 16:44:37 UTC
This package has been orphaned.

You can pick it up at https://src.fedoraproject.org/rpms/python-compreffor by clicking button "Take". If nobody picks it up, it will be retired and removed from a distribution.

Comment 10 Ben Beasley 2021-08-08 02:01:34 UTC
I have taken the package and will fix this promptly. A patch has been upstream for several months (https://github.com/googlefonts/compreffor/pull/142).

Comment 11 Fedora Update System 2021-08-08 23:37:12 UTC
FEDORA-2021-71520fb205 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-71520fb205

Comment 12 Fedora Update System 2021-08-08 23:38:32 UTC
FEDORA-2021-71520fb205 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 13 Fedora Update System 2021-08-09 02:02:51 UTC
FEDORA-2021-cccbcca112 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-cccbcca112

Comment 14 Fedora Update System 2021-08-09 02:03:59 UTC
FEDORA-2021-8621201e5f has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-8621201e5f

Comment 15 Fedora Update System 2021-08-10 01:15:59 UTC
FEDORA-2021-8621201e5f has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-8621201e5f`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-8621201e5f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Fedora Update System 2021-08-10 15:46:53 UTC
FEDORA-2021-cccbcca112 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-cccbcca112`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-cccbcca112

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 17 Fedora Update System 2021-08-18 01:10:34 UTC
FEDORA-2021-cccbcca112 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 18 Fedora Update System 2021-08-18 01:16:51 UTC
FEDORA-2021-8621201e5f has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.