Bug 1926795 - CannotRetrieveUpdates alerts on Critical severity
Summary: CannotRetrieveUpdates alerts on Critical severity
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 4.6.z
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.7.z
Assignee: Jack Ottofaro
QA Contact: Yang Yang
URL:
Whiteboard:
Depends On: 1926310
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-02-09 13:29 UTC by OpenShift BugZilla Robot
Modified: 2021-03-25 01:53 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-25 01:53:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-version-operator pull 516 0 None open [release-4.7] Bug 1926795: install/0000_90_cluster-version-operator_02_servicemonitor.yaml: adjust "CannotRetrieveUpdate... 2021-02-16 17:51:02 UTC
Red Hat Product Errata RHBA-2021:0821 0 None None None 2021-03-25 01:53:16 UTC

Comment 1 W. Trevor King 2021-02-09 16:18:46 UTC
Not a blocker, because the alert landed as critical in 4.6 [1], and we don't want to delay 4.7's GA on something that is not a 4.6->4.7 regression.

[1]: https://github.com/openshift/cluster-version-operator/blob/94358e80fa8151e43690d5925abc9337e90dca1c/install/0000_90_cluster-version-operator_02_servicemonitor.yaml#L47-L53

Comment 3 Yang Yang 2021-03-11 05:53:55 UTC
Verified with 4.7.0-0.nightly-2021-03-10-202622

Steps to verify:

1. Install a cluster with 4.7.0-0.nightly-2021-03-10-202622
2. After 1 hour, check CannotRetrieveUpdates alert

[root@preserve-yangyangmerrn-1 tmp]# token=`oc -n openshift-monitoring sa get-token prometheus-k8s` 
[root@preserve-yangyangmerrn-1 tmp]# curl -s -k -H "Authorization: Bearer $token" https://prometheus-k8s-openshift-monitoring.apps.yangyang0311.qe.gcp.devcluster.openshift.com/api/v1/alerts | jq '.data.alerts[]|select(.labels.alertname == "CannotRetrieveUpdates")'
{
  "labels": {
    "alertname": "CannotRetrieveUpdates",
    "endpoint": "metrics",
    "instance": "10.0.0.3:9099",
    "job": "cluster-version-operator",
    "namespace": "openshift-cluster-version",
    "pod": "cluster-version-operator-58cfdd7895-zgdrm",
    "service": "cluster-version-operator",
    "severity": "warning"        <------ severity is changed to warning
  },
  "annotations": {
    "message": "Cluster version operator has not retrieved updates in 1h 6m 4s. Failure reason VersionNotFound .  For more information refer to https://console-openshift-console.apps.yangyang0311.qe.gcp.devcluster.openshift.com/settings/cluster/."
  },
  "state": "firing",
  "activeAt": "2021-03-11T05:45:16.457044785Z",
  "value": "3.964457000017166e+03"
}

Moving it to verified state.

Comment 6 errata-xmlrpc 2021-03-25 01:53:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.3 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0821


Note You need to log in before you can comment on or make changes to this bug.