Bug 192702 - multilib -devel conflicts for libglade-java
multilib -devel conflicts for libglade-java
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libglade-java (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Stepan Kasal
:
Depends On:
Blocks: multilibdevel
  Show dependency treegraph
 
Reported: 2006-05-22 14:05 EDT by Jeremy Katz
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-06 04:45:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2006-05-22 14:05:27 EDT
The package contains conflicting -devel packages for multilib arches.

libglade-java-devel-2.12.3-0.i386.rpm
Preparing...                ##################################################
        file /usr/share/java/glade2.12-src-2.12.3.zip from install of libglade-j
ava-devel-2.12.3-0 conflicts with file from package libglade-java-devel-2.12.3-0
Comment 1 Ben Konrath 2006-06-14 00:25:39 EDT
Jeremy, the python script that checks for conflicts reports some files that are
marked with %doc as conflicting because these are generated with gjdoc and there
is a timestamp in a few of the files. Is rpm smart enough to work around files
in %doc or does this have to be fixed too? Thanks.
Comment 2 Jeremy Katz 2006-06-19 16:24:28 EDT
Nope, doc files can't conflict either.  
Comment 3 Ben Konrath 2006-10-03 17:38:34 EDT
The brp-java-repack-jars script, the updated zip creation and the updates to
gjdoc should fix this.

Stepan, I'm re-assigning this back to you so that you can test and rebuild for FC6.
Comment 4 Stepan Kasal 2006-10-06 04:45:11 EDT
The spec was fixed so that source zips are identical on all platforms.

Note You need to log in before you can comment on or make changes to this bug.