Bug 1927052 - Geeqie is not responding when started with the -r (--remote) option
Summary: Geeqie is not responding when started with the -r (--remote) option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: geeqie
Version: 33
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Matthew Miller
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-02-09 23:37 UTC by Vojtech Sobota
Modified: 2021-02-14 01:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-14 01:23:41 UTC
Type: Bug


Attachments (Terms of Use)

Description Vojtech Sobota 2021-02-09 23:37:03 UTC
Description of problem:
Geeqie is not responding when started with the -r (--remote) option. Similarly, if an existing instance of Geeqie is already running and another one is invoked with the option the existing window freezes.

Version-Release number of selected component (if applicable):
1.5.1-4.git26c4dad.fc33

How reproducible:
Always.

Steps to Reproduce:
1. Run Geeqie with the -r option.

       $ geeqie -r

Actual results:
The Geeqie window appears but it is not responsive. The console output shows something like this:

    Remote Geeqie not running, starting...

    (geeqie:5742): GLib-CRITICAL **: 23:18:14.789: g_io_channel_set_line_term: assertion 'length_size > G_MAXUINT' failed

    (geeqie:5744): GLib-CRITICAL **: 23:18:14.789: g_io_channel_set_line_term: assertion 'length_size > G_MAXUINT' failed

At this point I can hit Ctrl+C. If I do so an output such as the following appears and the Geeqie window becomes responsive.

    (geeqie:5744): GLib-WARNING **: 23:27:19.615: ../glib/giounix.c:410Error while getting flags for FD: Bad file descriptor (9)


    (geeqie:5744): GLib-WARNING **: 23:27:19.615: Invalid file descriptor.

    (geeqie:5744): GLib-WARNING **: 23:27:19.615: Invalid file descriptor.

    (geeqie:5744): GLib-WARNING **: 23:27:19.615: Error flushing string: Bad file descriptor

Expected results:
The Geeqie window appears and is responsive without having to intervene with Ctrl+C in the console.

Additional info:
There's been a GLib update recently. I wonder if it has anything to do with it. My glib2 version is 2.66.6-1.fc33.x86_64.

Comment 1 Ronald Warsow 2021-02-11 00:35:44 UTC
I see similar since an update the last 2 days.

trying to open an picture (jpeg) from nautilus get's me an black window in geepie and empty boxes on the left side.

running journalctl -f shows:

... geeqie[3965]: g_io_channel_set_line_term: assertion 'length_size > G_MAXUINT' failed
... geeqie[3969]: g_io_channel_set_line_term: assertion 'length_size > G_MAXUINT' failed

doing "geeqie <name>.jpeg" in an terminal geeqie works as usual !

Comment 2 Ronald Warsow 2021-02-12 16:20:49 UTC
my case seems to be fixed with glib2-2.66.7-1

thanks

Comment 3 Fedora Update System 2021-02-12 16:42:21 UTC
FEDORA-2021-e46198ba90 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-e46198ba90

Comment 4 Fedora Update System 2021-02-14 01:23:41 UTC
FEDORA-2021-e46198ba90 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.