Bug 192707 - multilib -devel conflicts for libgsf
Summary: multilib -devel conflicts for libgsf
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libgsf (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: multilibdevel
TreeView+ depends on / blocked
 
Reported: 2006-05-22 18:08 UTC by Jeremy Katz
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 1.14.1-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-23 15:00:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeremy Katz 2006-05-22 18:08:31 UTC
The package contains conflicting -devel packages for multilib arches.

libgsf-devel-1.14.1-2.i386.rpm
Preparing...                ##################################################
        file /usr/share/gtk-doc/html/gsf/GsfClipData.html from install of libgsf
-devel-1.14.1-2 conflicts with file from package libgsf-devel-1.14.1-2
        file /usr/share/gtk-doc/html/gsf/gsf-Bononbo.html from install of libgsf
-devel-1.14.1-2 conflicts with file from package libgsf-devel-1.14.1-2
        file /usr/share/gtk-doc/html/gsf/gsf-Compression.html from install of li
bgsf-devel-1.14.1-2 conflicts with file from package libgsf-devel-1.14.1-2
        file /usr/share/gtk-doc/html/gsf/gsf-GIOChannel.html from install of lib
gsf-devel-1.14.1-2 conflicts with file from package libgsf-devel-1.14.1-2
        file /usr/share/gtk-doc/html/gsf/gsf-GnomeVFS.html from install of libgs
f-devel-1.14.1-2 conflicts with file from package libgsf-devel-1.14.1-2
        file /usr/share/gtk-doc/html/gsf/gsf-Infile-reading-structed-files.html
from install of libgsf-devel-1.14.1-2 conflicts with file from package libgsf-de
vel-1.14.1-2

(etc for all gtk-doc)

Comment 1 Caolan McNamara 2006-05-22 18:58:50 UTC
Is there a fix design-pattern for this, i.e. is it something that afflicts all
gtk-doc using stuff like gtk itself and should be fixed in gtk-doc, or something
specific to libgsf ?

Comment 2 Jeremy Katz 2006-05-22 19:11:31 UTC
The best practice for gtk-doc using stuff (according to mclasen) is that the
generated gtk-doc should be shipped within the upstream tarball.

The root of the problem is that gtk-doc uses jade to generate the html and jade
doesn't generate consistent anchors in the html.  And fixing that is ...
non-trivial.

Comment 3 Caolan McNamara 2006-05-23 15:00:25 UTC
doh, spec actually configures with --enable-gtk-doc, easyfix methinks.


Note You need to log in before you can comment on or make changes to this bug.