Bug 19271 - RHN client allows blank Name, Address, City during product activation
RHN client allows blank Name, Address, City during product activation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration (Show other bugs)
unspecified
i386 Linux
high Severity high
: ---
: ---
Assigned To: Cristian Gafton
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-17 12:51 EDT by Martin C. Messer
Modified: 2015-01-07 18:42 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-07 13:38:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Martin C. Messer 2000-10-17 12:51:10 EDT
This causes failure of import into Oracle ERP/CRM due to lack of
information for site address creation. The default values ('Valued',
'Customer', '.', '.',) handled on the server side are very problematic for
a few reasons:

o Apparently '.' breaks the import process anyway.
o We will have thousands of 'Valued Customers' in Oracle. The customer
master is wreaked as it is.

Changes must be made either to the RHN client or the server side default
values being inserted in place of blank fields required by the Oracle
import.

[Paul, we've already talked about this but I wanted to make sure this
problem was logged for posterity. And because the work is not all yours
alone.]
Comment 1 Martin C. Messer 2000-10-17 12:52:08 EDT
Oops, I didn't know Paul wasn't an Assignee for RHN bugs.
Comment 2 Martin C. Messer 2000-10-17 12:55:32 EDT
An example:

http://www.redhat.com/support/supportable.html

username: silviobruschi

Registered on 09/25/00. Never imported. 

It does bother me that he registered a 6.2 box and not 7.
Comment 3 Jay Turner 2000-10-18 10:39:57 EDT
Those are required fields in the rhn_register process, so I think this is
probably a problem with the way that we are passing data rather than the client.
Comment 4 Paul Lindner 2000-10-31 13:57:35 EST
Marty, Samir,

What are the data requirements from the CRM side?  Minimum length for
address/name?

The problem is caused by:

 User minimally registers on RHN.
 User then proceeds to register product via the web site.

I think we should prompt for the user to fill in their data (like we do in
RHN...)  However this change
needs to happen in more locations.
Comment 5 Samir Kothari 2000-11-02 09:12:08 EST
We should require the same information we currently require for a customer
to register their product.

Comment 6 Jay Turner 2000-11-07 09:07:21 EST
Test Case for Live and Dev Systems: developer will have to create their own
accounts in order to see what characters are being defaulted into "empty"
fields.

Problem: users are creating profiles using the rhn_register program (but not
registering any products) and not supplying all user information (because they
are not required to and should not be.)  Then the user is logging into their
redhat.com accounts they just created and are registering products (which
requires that all user information be present.) These records are failing import
into Oracle becuase the information which was not provided by the user has been
filled in with characters which are not valid for Oracle import (like "." for
the address fields.

Expected behavior after fix: user will be able to create a profile by providing
only username, password and email address; user will then be able to go back to
that account and register a product, thus forcing import into Oracle; import
will be successful and product will be entitled.
Comment 7 Martin C. Messer 2000-11-07 11:40:23 EST
The real trick here is not so much the default data you're using in blank fields
(which may or may not be the real problem) but that it seems the RHN client is
not using the same methods to create user accounts in the web tables. 

If the redhat.com/join process isn't mirrored completely with this new client,
then it will never work, regardless of the defaults you use.
Comment 8 Martin C. Messer 2000-11-07 13:38:25 EST
More info: the problem is definetly _not_ the '.' in the fields but that the
required fields are not being populated at all.

I registered this user account today, and was able to activate a product that
imported into Oracle: yo_mama

Look at the record here:

http://www.redhat.com/support/supportable.html

As you can see, I have '.' in every required field (other than email and login)
and there was no problem on the Oracle end. The problem with the RHN client is
that is doesn't put anything in the required fields. The required fields haven't
changed in quite a while, and can be found here

http://www.redhat.com/join
Comment 9 Jay Turner 2001-01-17 10:40:17 EST
OK, think that we actually have this resolved on the live site.  All information
from the registration client is making it to the oracle database now.

I'm closing this bug out for now.  Will reopen if stuff starts to go crazy
again.  (jkt; 1/17/01)

Note You need to log in before you can comment on or make changes to this bug.