Bug 192731 - multilib -devel conflicts for libXxf86vm
Summary: multilib -devel conflicts for libXxf86vm
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libXxf86vm   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: multilibdevel
TreeView+ depends on / blocked
 
Reported: 2006-05-22 18:22 UTC by Jeremy Katz
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-05 11:36:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeremy Katz 2006-05-22 18:22:10 UTC
The package contains conflicting -devel packages for multilib arches.

libXxf86vm-devel-1.0.1-1.i386.rpm
Preparing...                ##################################################
        file /usr/share/man/man3/XF86VidModeDeleteModeLine.3x.gz from install of
 libXxf86vm-devel-1.0.1-1 conflicts with file from package libXxf86vm-devel-1.0.
1-1
        file /usr/share/man/man3/XF86VidModeGetAllModeLines.3x.gz from install o
f libXxf86vm-devel-1.0.1-1 conflicts with file from package libXxf86vm-devel-1.0
.1-1
        file /usr/share/man/man3/XF86VidModeGetDotClocks.3x.gz from install of l
ibXxf86vm-devel-1.0.1-1 conflicts with file from package libXxf86vm-devel-1.0.1-
1
        file /usr/share/man/man3/XF86VidModeGetGamma.3x.gz from install of libXx
f86vm-devel-1.0.1-1 conflicts with file from package libXxf86vm-devel-1.0.1-1
        file /usr/share/man/man3/XF86VidModeGetGammaRamp.3x.gz from install of l
ibXxf86vm-devel-1.0.1-1 conflicts with file from package libXxf86vm-devel-1.0.1-
1
        file /usr/share/man/man3/XF86VidModeGetGammaRampSize.3x.gz from install
of libXxf86vm-devel-1.0.1-1 conflicts with file from package libXxf86vm-devel-1.
0.1-1
        file /usr/share/man/man3/XF86VidModeGetModeLine.3x.gz from install of li
bXxf86vm-devel-1.0.1-1 conflicts with file from package libXxf86vm-devel-1.0.1-1
        file /usr/share/man/man3/XF86VidModeGetMonitor.3x.gz from install of lib
Xxf86vm-devel-1.0.1-1 conflicts with file from package libXxf86vm-devel-1.0.1-1
        file /usr/share/man/man3/XF86VidModeGetPermissions.3x.gz from install of
 libXxf86vm-devel-1.0.1-1 conflicts with file from package libXxf86vm-devel-1.0.
1-1
        file /usr/share/man/man3/XF86VidModeGetViewPort.3x.gz from install of li
bXxf86vm-devel-1.0.1-1 conflicts with file from package libXxf86vm-devel-1.0.1-1
        file /usr/share/man/man3/XF86VidModeLockModeSwitch.3x.gz from install of
 libXxf86vm-devel-1.0.1-1 conflicts with file from package libXxf86vm-devel-1.0.
1-1
        file /usr/share/man/man3/XF86VidModeModModeLine.3x.gz from install of li
bXxf86vm-devel-1.0.1-1 conflicts with file from package libXxf86vm-devel-1.0.1-1
        file /usr/share/man/man3/XF86VidModeQueryExtension.3x.gz from install of
 libXxf86vm-devel-1.0.1-1 conflicts with file from package libXxf86vm-devel-1.0.
1-1
        file /usr/share/man/man3/XF86VidModeQueryVersion.3x.gz from install of l
ibXxf86vm-devel-1.0.1-1 conflicts with file from package libXxf86vm-devel-1.0.1-
1
        file /usr/share/man/man3/XF86VidModeSetClientVersion.3x.gz from install
of libXxf86vm-devel-1.0.1-1 conflicts with file from package libXxf86vm-devel-1.
0.1-1
        file /usr/share/man/man3/XF86VidModeSetGamma.3x.gz from install of libXx
f86vm-devel-1.0.1-1 conflicts with file from package libXxf86vm-devel-1.0.1-1
        file /usr/share/man/man3/XF86VidModeSetGammaRamp.3x.gz from install of l
ibXxf86vm-devel-1.0.1-1 conflicts with file from package libXxf86vm-devel-1.0.1-
1
        file /usr/share/man/man3/XF86VidModeSetViewPort.3x.gz from install of li
bXxf86vm-devel-1.0.1-1 conflicts with file from package libXxf86vm-devel-1.0.1-1
        file /usr/share/man/man3/XF86VidModeSwitchMode.3x.gz from install of lib
Xxf86vm-devel-1.0.1-1 conflicts with file from package libXxf86vm-devel-1.0.1-1
        file /usr/share/man/man3/XF86VidModeSwitchToMode.3x.gz from install of l
ibXxf86vm-devel-1.0.1-1 conflicts with file from package libXxf86vm-devel-1.0.1-
1
        file /usr/share/man/man3/XF86VidModeValidateModeLine.3x.gz from install
of libXxf86vm-devel-1.0.1-1 conflicts with file from package libXxf86vm-devel-1.
0.1-1

Comment 1 Mike A. Harris 2006-05-23 14:31:15 UTC
Changing state to ASSIGNED.

Comment 2 Mike A. Harris 2006-06-05 11:36:19 UTC
This was caused due to the %makeinstall macro being an unreliable installation
mechanism.  While it is no doubt a flaw in upstream X makefiles, %makeinstall
has been observed to generally be an unreliable thing, so I have changed the
rpm spec to use "make install DESTDIR=..." instead.

Fixed in 1.0.1-2


Note You need to log in before you can comment on or make changes to this bug.