Bug 1927636 - notmuch: FTBFS in Fedora rawhide
Summary: notmuch: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: notmuch
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael J Gruber
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F35FTBFS
TreeView+ depends on / blocked
 
Reported: 2021-02-11 08:21 UTC by Tomáš Hrnčiar
Modified: 2021-02-18 11:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-18 11:25:48 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-02-11 08:21:12 UTC
Description of problem:
Package notmuch fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
0.31.3-4.fc34

Steps to Reproduce:
koji build --scratch f34 notmuch-0.31.3-4.fc34.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/notmuch

Comment 1 Michael J Gruber 2021-02-11 11:18:30 UTC
The FTBFS is not a python 3.10 issue. It is the same as these:

https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/J3P4TRHLWNDIKXF76OLYZNAPTABCZ3U5/

I won't remove the PYTHON3.10 blocker, though, until I fixed the c/c++ glib include issue and know for sure that there is no py3.10 issue on top.

Comment 2 Tomáš Hrnčiar 2021-02-12 07:09:41 UTC
We are rebuilding all Python packages in COPR repository with latest alphas of Python 3.10. Thus we are using PYTHON3.10 tracker for any failing package using Python no matter of the reason of failure. We do this for tracking purposes so we know that failure is reported and it gets ignored in our scripts. Every time when you push new commit into dist-git it will trigger another build in our Python 3.10 COPR. If it fails again I will get back to you with another Python 3.10 specific bugzilla. But as you can see here [0] your package is again building alright. Thank you for the fix. 

[0] https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/notmuch/

Comment 3 Michael J Gruber 2021-02-12 09:56:10 UTC
(In reply to Tomáš Hrnčiar from comment #2)
> We are rebuilding all Python packages in COPR repository with latest alphas
> of Python 3.10. Thus we are using PYTHON3.10 tracker for any failing package
> using Python no matter of the reason of failure. We do this for tracking
> purposes so we know that failure is reported and it gets ignored in our
> scripts. Every time when you push new commit into dist-git it will trigger
> another build in our Python 3.10 COPR. If it fails again I will get back to
> you with another Python 3.10 specific bugzilla. But as you can see here [0]
> your package is again building alright. Thank you for the fix. 
> 
> [0]
> https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/notmuch/

Thanks for the info (which I should have looked up myself). You're doing things the right way for py3.10!

As for glib ... My package is fixed, but many others FTBFS now due to a glib change, so PYTHON3.10 will have many false positives.


Note You need to log in before you can comment on or make changes to this bug.