This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 192781 - Something wrong in gtype.c makes totem and gnome-system-log (at least) crash on Itanium
Something wrong in gtype.c makes totem and gnome-system-log (at least) crash ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glib (Show other bugs)
rawhide
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2006-05-22 17:57 EDT by Émeric Maschino
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-22 16:49:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Émeric Maschino 2006-05-22 17:57:15 EDT
Description of problem:

gnome-system-log and totem are both crashing due to something wrong at line 2717
in gtype.c. Here's the gdb output for gnome-system-log:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 2305843009256628736 (LWP 23154)]
0x2000000001477750 in IA__g_type_check_instance_cast (
    type_instance=0x60000000000cc210, iface_type=816624) at gtype.c:2717
2717      if (/* support_inheritance && */

And here's the gdb output for totem:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 2305843009260121520 (LWP 23086)]
0x200000000136a651 in IA__g_type_check_instance_is_a (type_instance=Variable
"type_instance" is not available.
)
    at gtype.c:2717
2717      if (/* support_inheritance && */

This issue is there since, at least January 2006, but I initially thought it was
different issues for gnome-system-log and totem. Hence the very late bug report
against the right (I think) component. Sorry!

Version-Release number of selected component (if applicable):

Current Rawhide glib-1.2.10-18.2.2

How reproducible:

Always

Steps to Reproduce:
1. Start totem or gnome-system-log
2. 
3.
  
Actual results:

Program crashes with a SIGSEGV signal

Expected results:

Program should work fine

Additional info:
Comment 1 Émeric Maschino 2006-06-14 18:33:57 EDT
gnome-system-log (from gnome-utils-2.15.3-1) is now working fine. totem is still
crashing however for the same reason. Is this really a glib issue or a totem issue?
Comment 2 Émeric Maschino 2006-07-22 16:03:07 EDT
This was indeed a gstreamer issue. Please see bug #179654 for details. This one
can now be safely closed ;-)

Note You need to log in before you can comment on or make changes to this bug.