This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 192782 - Why are Red Hat Network options shown in Fedora menus?
Why are Red Hat Network options shown in Fedora menus?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rhn-applet (Show other bugs)
5
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Robin Norwood
Beth Nackashi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-22 17:59 EDT by Andrew D. Stadler
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-29 17:30:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew D. Stadler 2006-05-22 17:59:41 EDT
Description of problem:

Upgrading from FC3 to FC5 I see that the old rhn/up2date system has been deprecated and replaced by 
pup/pirut/yum.  OK.

However, this took me a while to figure out because in the gnome main menu, system tools, there was 
good old "Red Hat Network" and "Red Hat Network Alert Icon".  I spent a while trying to get them to 
work before I found out what was going on.

My basic point is, if RHN has been deprecated, it should be removed from menus and the distribution, 
too, right?


Version-Release number of selected component (if applicable):

rhn-applet-2.1.16-1
Comment 1 John Thacker 2006-10-29 17:30:53 EST
Did you upgrade directly from FC3 to FC5?  That's not officially support.  While
rhn-applet and up2date were replaced by pup/pirut/yum, anaconda does not
generally remove deprecated programs from an existing install.  Users may depend
on those old programs, and it would be a bad default.  (Obsoletes are a bit
different, but for various reasons pirut does not explicitly Obsolete rhn-applet
and up2date.)

So I'm assuming by your comment that you still have rhn-applet and possibly
up2date from FC3 installed.  Since they're installed, their menu items appear. 
This perhaps would not have happened had you not upgraded directly from FC3 to
FC5.  On fresh installs, they certainly do not appear, since rhn-applet and
up2date were indeed removed from the distribution.

Note You need to log in before you can comment on or make changes to this bug.