Bug 192791 - Realplayer 10 --> video doesn't work if SElinux is turned on.
Summary: Realplayer 10 --> video doesn't work if SElinux is turned on.
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy   
(Show other bugs)
Version: 5
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-23 03:29 UTC by Hal Canary
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-14 15:17:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages output for bug 192791 (4.90 KB, text/plain)
2006-05-24 04:30 UTC, Hal Canary
no flags Details

Description Hal Canary 2006-05-23 03:29:24 UTC
*** Description of problem: ***

Since I installed FC5, the video on Realplayer doesn't work.  I changed the
SELinux policy from "enforcing" to "disabled" and the video began working.

Other media players such as mplayer and xine work just fine.


*** Version-Release number of selected component (if applicable): ***

$ uname -srpi
Linux 2.6.16-1.2111_FC5 athlon i386

$ rpm -q RealPlayer
RealPlayer-10.0.7.785-20060201

$ rpm -q  selinux-policy
selinux-policy-2.2.36-2.fc5

*** How reproducible: ***

Always

*** Steps to Reproduce: ***
1.  /usr/bin/system-config-securitylevel -> set policy to "enforcing"
2.  Download rpm of realplayer from "http://www.real.com/linux/".
3.  Install rpm
4.  Watch a video:
     /usr/local/RealPlayer/realplay
'http://show.real.com/show/_/action/ram/playlistid/10255705/clipnum/5/&pageid=movies.defaultPage&pageregion=A3'

  


*** See also: ***
http://real.lithium.com/real/board/message?board.id=rhapsody&message.id=5166
https://bugs.helixcommunity.org/show_bug.cgi?id=4996

Comment 1 Daniel Walsh 2006-05-23 18:23:15 UTC
What avc messages are you seeing in /var/log/messages?   Have you tried to
upgrade to the latest released selinux policy>

If you see a shared library with an error of execmod on it,  You can 
execute 

chcon  -t textrel_shlib_t PATHTOLIB

And try it again.

Comment 2 Hal Canary 2006-05-24 04:30:01 UTC
Created attachment 129899 [details]
/var/log/messages output for bug 192791

Comment 4 Daniel Walsh 2007-02-14 15:17:57 UTC
All of these bugs should be fixed in FC6,  You could attempt to use the FC6
policy on FC5 or upgrade.  Or you could use 

audit2allow -M mypolicy -i /var/log/audit/audit.log 
and build local customized policy


Note You need to log in before you can comment on or make changes to this bug.