Bug 192798 - syck needs a rebuild for newer php in Core
syck needs a rebuild for newer php in Core
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: syck (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Oliver Falk
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-23 01:59 EDT by Kevin Kofler
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.55-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-26 12:18:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Kofler 2006-05-23 01:59:13 EDT
Description of problem:
package: syck-php - 0.55-7.fc5.i386 from fedora-extras-5-i386
  unresolved deps: 
     php = 0:5.1.2

Version-Release number of selected component (if applicable):
syck-php-0.55-7.fc5.i386

How reproducible:
Always.

Steps to Reproduce:
Just look at the repoclosure output.
  
Actual results:
The above error message shows up, breaking upgrades for users of the affected 
packages.

Expected results:
No error messages.
Comment 1 Till Maas 2006-08-25 15:24:39 EDT
Oliver, why is this bug not yet fixed since it seams to be easy. This bug is 
open now for more than three months and you did not even comment it. If you do 
not maintain syck anymore, please announce this on fedora-extras-list. If you 
want please fix this or write what is hindering you.
Comment 2 Till Maas 2006-08-25 16:04:27 EDT
Trying to build the current spec in mock for devel I get the following error:

+ /usr/bin/make 'CFLAGS=-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
 -fasynchronous-unwind-tables'
cd . && /bin/sh /builddir/build/BUILD/syck-0.55/config/missing --run 
aclocal-1.9
 cd . && /bin/sh /builddir/build/BUILD/syck-0.55/config/missing --run 
automake-1.9 --foreign
lib/Makefile.am:7: Libtool library used but `LIBTOOL' is undefined
lib/Makefile.am:7:
lib/Makefile.am:7: The usual way to define `LIBTOOL' is to add 
`AC_PROG_LIBTOOL'
lib/Makefile.am:7: to `configure.in' and run `aclocal' and `autoconf' again.
make: *** [Makefile.in] Error 1
Comment 3 Jason Tibbitts 2006-08-26 12:18:26 EDT
I fixed the package to build in the minimal buildroots (needed BR: libtool) and
pushed a build through for FC5 and devel.
Comment 4 Oliver Falk 2006-09-08 07:15:29 EDT
Thanks Jason. I was unable to do it, since I'm very busy at work at the moment.

Note You need to log in before you can comment on or make changes to this bug.