Bug 192805 - No usb printing after update
No usb printing after update
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
:
: 193852 (view as bug list)
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-05-23 04:35 EDT by Erik Pedersen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2.1-1.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-23 18:15:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
cupsd.conf (21.70 KB, text/plain)
2006-05-23 07:22 EDT, Erik Pedersen
no flags Details
50-udev.rules (13.61 KB, text/plain)
2006-05-23 09:26 EDT, Erik Pedersen
no flags Details

  None (edit)
Description Erik Pedersen 2006-05-23 04:35:31 EDT
Description of problem:
After an update I can no longer print at all
printer epson disabled since Mon 22 May 2006 07:30:41 AM EDT -
        Unable to open USB device "usb:/dev/usb/lp0": Permission denied
The date here is because I did a reboot

The yum update picked up the following so I am not sure exactly what it is 
that causes the problem

May 21 03:19:09 Updated: glibc-common.i386 2.4-8
May 21 03:19:37 Updated: glibc.i686 2.4-8
May 21 03:19:37 Updated: cups-libs.i386 1:1.2.0-1.1
May 21 03:19:39 Updated: policycoreutils.i386 1.30.8-1.fc5
May 21 03:19:39 Updated: libsane-hpaio.i386 0.9.11-1.1
May 21 03:19:42 Updated: glibc-headers.i386 2.4-8
May 21 03:19:42 Updated: hpijs.i386 1:0.9.11-1.1
May 21 03:19:45 Updated: selinux-policy.noarch 2.2.38-1.fc5
May 21 03:19:47 Updated: mysql.i386 5.0.21-2.FC5.1
May 21 03:20:24 Updated: kdebase.i386 6:3.5.2-7.3.fc5.kde
May 21 03:20:36 Updated: ntp.i386 4.2.0.a.20050816-11.FC5
May 21 03:20:37 Updated: lame.i386 3.96.1-6.lvn5
May 21 03:20:41 Updated: cups.i386 1:1.2.0-1.1
May 21 03:20:43 Updated: libkipi.i386 0.1.4-1.fc5
May 21 03:20:47 Updated: hplip.i386 0.9.11-1.1
May 21 03:20:48 Updated: pirut.noarch 1.0.3-0.fc5
May 21 03:20:49 Updated: libkexif.i386 0.2.3-1.fc5
May 21 03:20:50 Updated: psmisc.i386 22.2-1.1
May 21 03:20:51 Updated: nscd.i386 2.4-8
May 21 03:20:52 Updated: glibc-devel.i386 2.4-8
May 21 03:22:22 Updated: selinux-policy-targeted.noarch 2.2.38-1.fc5
May 21 03:22:23 Updated: vnc-server.i386 4.1.1-38.fc5



Version-Release number of selected component (if applicable):


How reproducible:
Can not print ever

Steps to Reproduce:
1.try to print
2.
3.
  
Actual results:
nothing

Expected results:
output

Additional info:
Comment 1 Tim Waugh 2006-05-23 04:50:48 EDT
Please attach:

1. your /etc/cups/cupsd.conf, and

2. the output of:

  ls -l /dev/usb/lp0

Thanks.
Comment 2 Tim Waugh 2006-05-23 05:18:53 EDT
Oh, also:

3. the output of 'lpstat -s'
Comment 3 Erik Pedersen 2006-05-23 07:22:06 EDT
Created attachment 129850 [details]
cupsd.conf

Maybe I should add that the printer worked fine until that update.
Comment 4 Erik Pedersen 2006-05-23 07:33:16 EDT
system default destination: epson
device for epson: usb:/dev/usb/lp0
device for hp: ipp://denal:631/printers/hp

ls -l /dev/usb/lp0
crw------- 1 inger root 180, 0 May 22 08:12 /dev/usb/lp0
Comment 5 Tim Waugh 2006-05-23 08:08:47 EDT
Oh, there's the problem: /dev/usb/lp0 is meant to have 'rw' for group 'lp'.

Have you changed that on purpose?
Comment 6 Erik Pedersen 2006-05-23 08:17:19 EDT
No I did not do anything other than yum update from the core, extras, livna 
and kde-redhat stable repositories. I changed it now, but it does not seem to 
help
ls -l /dev/usb/lp0
crw-rw---- 1 root lp 180, 0 May 22 08:12 /dev/usb/lp0
[root@laptop inger]# lpstat -p
printer epson disabled since Mon 22 May 2006 07:30:41 AM EDT -
        Unable to open USB device "usb:/dev/usb/lp0": Permission denied

Comment 7 Tim Waugh 2006-05-23 08:18:14 EDT
You might have to re-enable the queue with 'cupsenable epson'.
Comment 8 Erik Pedersen 2006-05-23 08:22:13 EDT
Thanks that did it. I do however still wonder how those permissions got 
changed, I certainly did not change them. I have a cronjob running yum update 
every weekend and all of a sudden sunday I could no longer print. It is 
probably not cups though
Comment 9 Erik Pedersen 2006-05-23 08:46:09 EDT
Except I still can't print. I tried a reboot and then tried to print. Nothing 
happened and the permissions were back to the ones mentioned above. Because of 
a HIGHMEM problem I have to compile the kernel myself on this computer, but I 
take your kernel source, and only change HIGHMEM parameters in the config, but 
of course I exclude kernel from yum update. Could that be the problem? There 
was no reboot before the problem first occurred though
Comment 10 Erik Pedersen 2006-05-23 08:57:31 EDT
OK after every reboot, the permissions on /dev/usb/lp0 are wrong. When I 
correct these permissions I can print now. I don't reboot so often, but 
nevertheless, I wonder where this problem comes from
Comment 11 Erik Pedersen 2006-05-23 09:02:20 EDT
Another strange problem with this printer, epson stylus cx5400, after the 
upgrade to fc5 is that the printer continues blinking after the print job is 
done, and you have to turn that printer on and off to get it back to normal. 
That did not use to happen when i was running fc3. Somehow the print jobs are 
not terminated correctly.
Comment 12 Tim Waugh 2006-05-23 09:12:45 EDT
Could you attach your /etc/udev/rules.d/50-udev.rules file please?
Comment 13 Erik Pedersen 2006-05-23 09:25:22 EDT
I will do that. Actually the permissions and ownerships change whenever I log 
out and in
Comment 14 Erik Pedersen 2006-05-23 09:26:40 EDT
Created attachment 129857 [details]
50-udev.rules
Comment 15 Erik Pedersen 2006-05-23 09:50:05 EDT
I am using kdm as login manager and kdebase was updated too, so could that be 
the problem? When I log out permissions as seen from another computer get 
changed to root.root 600, I guess that is kdm doing that or what?
Comment 16 Tim Waugh 2006-05-23 10:38:03 EDT
What about /etc/security/console.perms and anything in
/etc/security/console.perms.d?
Comment 17 Erik Pedersen 2006-05-23 10:46:49 EDT
I am at work now, but I will send them when I get home. I certainly did not 
change anything there not knowing about them, but I looked in there and the 
permissions fit with the fact that this printer is also a scanner, and there 
is a link scanner-lp0 to usb/lp0. Could that be it?
Comment 18 Tim Waugh 2006-05-23 18:15:53 EDT
Sounds like something from livna or kde-redhat has messed that up -- it isn't
supposed to be like that.

Anyway, cups-1.2.1-1.2 makes the usb backend run as root now because of a
separate KDE bug, so that will fix this for the time being.
Comment 19 Tim Waugh 2006-06-07 08:40:04 EDT
*** Bug 193852 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.