Bug 1928062 - python-pyvlx fails to build with Python 3.10: AttributeError: Command: no attribute 'GW_LEAVE_LEARN_STATE_REQ'
Summary: python-pyvlx fails to build with Python 3.10: AttributeError: Command: no att...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-pyvlx
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fabian Affolter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1969113 (view as bug list)
Depends On:
Blocks: F35FTBFS F35FailsToInstall PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-02-12 09:53 UTC by Tomáš Hrnčiar
Modified: 2021-07-26 09:17 UTC (History)
3 users (show)

Fixed In Version: python-pyvlx-0.2.19-4.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-26 09:17:44 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-02-12 09:53:23 UTC
python-pyvlx fails to build with Python 3.10.0a5.

=================================== FAILURES ===================================
_____________ TestFrameLeaveLearnStateRequest.test_frame_from_raw ______________

self = <frame_leave_learn_state_req_test.TestFrameLeaveLearnStateRequest testMethod=test_frame_from_raw>

    def test_frame_from_raw(self):
        """Test parse FrameLeaveLearnStateRequest from raw."""
>       frame = frame_from_raw(self.EXAMPLE_FRAME)

test/frame_leave_learn_state_req_test.py:22: 
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 
../../BUILDROOT/python-pyvlx-0.2.19-2.fc35.x86_64/usr/lib/python3.10/site-packages/pyvlx/api/frame_creation.py:41: in frame_from_raw
    frame = create_frame(command)
../../BUILDROOT/python-pyvlx-0.2.19-2.fc35.x86_64/usr/lib/python3.10/site-packages/pyvlx/api/frame_creation.py:180: in create_frame
    if command == command.GW_LEAVE_LEARN_STATE_REQ:
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 

self = <enum.property object at 0x7fbc63e37eb0>
instance = <Command.GW_LEAVE_LEARN_STATE_REQ: 14>, ownerclass = <enum 'Command'>

    def __get__(self, instance, ownerclass=None):
        if instance is None:
            try:
                return ownerclass._member_map_[self.name]
            except KeyError:
                raise AttributeError(
                        '%s: no attribute %r' % (ownerclass.__name__, self.name)
                        )
        else:
            if self.fget is None:
>               raise AttributeError(
                        '%s: no attribute %r' % (ownerclass.__name__, self.name)
                        )
E               AttributeError: Command: no attribute 'GW_LEAVE_LEARN_STATE_REQ'

/usr/lib64/python3.10/enum.py:146: AttributeError
=========================== short test summary info ============================
FAILED test/frame_leave_learn_state_req_test.py::TestFrameLeaveLearnStateRequest::test_frame_from_raw
======================== 1 failed, 287 passed in 0.84s =========================

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01959124-python-pyvlx/

For all our attempts to build python-pyvlx with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-pyvlx/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Fabian Affolter 2021-03-03 09:09:49 UTC
https://github.com/Julius2342/pyvlx/issues/61

Comment 2 Miro Hrončok 2021-06-04 20:13:46 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 3 Miro Hrončok 2021-06-07 22:58:30 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 4 Miro Hrončok 2021-06-08 11:31:56 UTC
*** Bug 1969113 has been marked as a duplicate of this bug. ***

Comment 5 Miro Hrončok 2021-06-15 20:25:48 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 6 Miro Hrončok 2021-07-07 11:23:02 UTC
Hello,

This is the second reminder (step 4 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 7 Fedora Release Engineering 2021-07-11 04:22:34 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 35.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2021-04-09).

A week before the mass branching of Fedora 36 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 34 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-36/f-36-key-tasks.html


Note You need to log in before you can comment on or make changes to this bug.