Bug 1928065 - python-smbprotocol fails to build with Python 3.10: TypeError: invalid Flag 'BufferType' -- missing values: 4, 8 [NEEDINFO]
Summary: python-smbprotocol fails to build with Python 3.10: TypeError: invalid Flag '...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: python-smbprotocol
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fabian Affolter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1969135 (view as bug list)
Depends On: 1928066
Blocks: F35FTBFS F35FailsToInstall PYTHON3.10
TreeView+ depends on / blocked
 
Reported: 2021-02-12 09:56 UTC by Tomáš Hrnčiar
Modified: 2021-07-12 12:44 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-12 12:44:39 UTC
Type: Bug
mhroncok: needinfo? (mail)


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-02-12 09:56:57 UTC
python-smbprotocol fails to build with Python 3.10.0a5.

+ /usr/bin/pytest -v tests
ImportError while loading conftest '/builddir/build/BUILD/smbprotocol-1.1.0/tests/conftest.py'.
tests/conftest.py:9: in <module>
    from smbclient import (
smbclient/__init__.py:7: in <module>
    from smbclient._pool import (
smbclient/_pool.py:14: in <module>
    from smbprotocol.session import (
smbprotocol/session.py:7: in <module>
    import spnego
/usr/lib/python3.10/site-packages/spnego/__init__.py:12: in <module>
    from spnego._context import (
/usr/lib/python3.10/site-packages/spnego/_context.py:37: in <module>
    from spnego.iov import (
/usr/lib/python3.10/site-packages/spnego/iov.py:14: in <module>
    class BufferType(IntFlag):
/usr/lib64/python3.10/enum.py:527: in __new__
    raise TypeError(
E   TypeError: invalid Flag 'BufferType' -- missing values: 4, 8

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01958599-python-smbprotocol/

For all our attempts to build python-smbprotocol with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-smbprotocol/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Jordan Borean 2021-05-06 20:31:05 UTC
This is related to https://bugzilla.redhat.com/show_bug.cgi?id=1928066. Copying response here as well.

This was also reported with https://github.com/jborean93/pyspnego/issues/10 and has been subsequently fixed with https://github.com/jborean93/pyspnego/pull/11. I plan on creating a release with this change sometime soon which should fix this problem.

Comment 2 Miro Hrončok 2021-06-04 20:15:39 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 3 Miro Hrončok 2021-06-07 23:00:01 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 4 Miro Hrončok 2021-06-08 11:33:15 UTC
*** Bug 1969135 has been marked as a duplicate of this bug. ***

Comment 5 Miro Hrončok 2021-06-15 20:25:51 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 6 Miro Hrončok 2021-07-07 11:23:12 UTC
Hello,

This is the second reminder (step 4 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 7 Fedora Release Engineering 2021-07-11 04:22:35 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 35.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2021-04-09).

A week before the mass branching of Fedora 36 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 34 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-36/f-36-key-tasks.html

Comment 8 Miro Hrončok 2021-07-12 12:44:39 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok@redhat.com).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 35.

Thanks for taking care of it!


Note You need to log in before you can comment on or make changes to this bug.