Bug 192810 - [ml_IN]GSUB issues in new Malayalam font
[ml_IN]GSUB issues in new Malayalam font
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fonts-indic (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rahul Bhalerao
: i18n
Depends On:
Blocks: 206431
  Show dependency treegraph
 
Reported: 2006-05-23 07:01 EDT by Ani Peter
Modified: 2016-07-31 21:30 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-27 08:11:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ani Peter 2006-05-23 07:01:27 EDT
Categorising the GSUB issues into three for better understanding.

CATEGORY - I
Description of problem:
The result obtained for the combination of following consonants with (U + 0D4D)
and (U + 0D32) MUST BE obtained ONLY with the combination of these consonants
with (U + 0D4D) and (U + 0D33). These consonants are:
U + 0D15
U + 0D2A
U + 0D17
U + 0D2C
U + 0D2E 
U + 0D36
U + 0D38
U + 0D39.
For rest consonants, whether this GSUB rule should be applied or not is under
research. It is to be confirmed and verified from senior Malayalam intellucts.

Version-Release number of selected component (if applicable):

How reproducible:
Always

Steps to Reproduce:
1.Open kbabel application
2.Type U + 0D15 (eg)
3.Type U + 0D4D
4.Type U + 0D32
  
Actual results:
For eg: (U + 0D15) + (U + 0D4D) + (U + 0D32) = result, which is a new
character(glyph).

Expected results:
For the above example :
(U + 0D15) + (U + 0D4D) + (U + 0D33) =  result, which is formed by the above
mentioned wrong key combination(in the Actual results section).


Additional info:

CATEGORY - II
Description of problem:
Two combinations missing. ie, Rule needed for two different key combinations to
form new characters(glyphs).

The key combinations are :
(i)  (U + 0D28) + (U + 0D4D) + (U + 0D15)
(ii) (U + 0D28) + (U + 0D4D) + (U + 0D1A)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
case (i) - first combination
1.Open Kbabel application
2.Type U + 0D28
3.Type U + 0D4D
4.Type U + 0D15

case (ii) - second combination
1.Open Kbabel application
2.Type U + 0D28
3.Type U + 0D4D
4.Type U + 0D1A
Actual results:
for both cases (i) and (ii), the letters displayed according to the key sequence

Expected results:
For both combinations:
(i)  (U + 0D28) + (U + 0D4D) + (U + 0D15)
(ii) (U + 0D28) + (U + 0D4D) + (U + 0D1A)
two new characters(glyphs) are expected.



Additional info:
Comment 2 Darshan Santani 2006-05-24 01:12:14 EDT
Leon, I think it is the problem with the malayalam GSUB table and it has nothing
to do with the pango shaper engine.
Comment 3 Ani Peter 2006-05-24 01:44:39 EDT
Hi team,

I am sorry that I made a mistake. As per I have reported, in CATEGORY - II, the
case (ii) combination is missing. 
But in this combination the keys must be,

(U + 0D1E) + (U + 0D4D) + (U + 0D1A)
instead of
(U + 0D28) + (U + 0D4D) + (U + 0D1A), and this is perfectly working fine in our
new font.

It was a confusion among the keys. Its confirmed and verified.
My apology for the same.
Comment 4 Liang Zhang 2006-05-24 05:44:43 EDT
The indic engine of pango reorders the unicode strings for conjuctions, and the
unicode strings of being reordered are handled in FreeType. FreeType analyses
the unicode strings and looks for the conjuction's glyph position in GSUB and
GPOS of font file as the order of the unicode strings.
The malayalam has some special rules of conjuction, these rules are different
with the common rules of conjuction of indic. But the indic engine of pango
reorders the unicode strings as the common rules of conjuction of indic. So
there are many bugs in malayalam. And some rules of malayalam conjuction are
fuzzy in unicode specification.
I fainted at last, because I can not know which is right or wrong.  :)
I wrote and committed a patch for fixing some bugs of malayalam's conjuction
some months ago. And it is waiting for testing and reviewing.
http://bugzilla.gnome.org/show_bug.cgi?id=121672
http://bugzilla.gnome.org/show_bug.cgi?id=335811
Perhaps it can help you. :)

Comment 6 Ani Peter 2006-05-25 06:17:34 EDT
Description of problem:
We have  category of conjuncts which are formed by
case (i)  :any consonant + (U + 0D4D) + (U + 0D2F)
case (ii) :any consonant + (U + 0D4D) + (U + 0D30)
case (iii):any consonant + (U + 0D4D) + (U + 0D35)

In the present scenario, for each case, whenever we have these three characters
together, it is substituted by the respective conjunct. But this is not needed
all the times, in some words we need the display to be according to the key
sequence.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Case (i):
1.Open Kabel Application
2.Type any consonant from (U + 0D15) to (U + 0D39)
3.Type (U + 0D4D)
4.Type (U + 0D2F)

Case (ii):
1.Open Kabel Application
2.Type any consonant from (U + 0D15) to (U + 0D39)
3.Type (U + 0D4D)
4.Type (U + 0D30)

Case (iii):
1.Open Kabel Application
2.Type any consonant from (U + 0D15) to (U + 0D39)
3.Type (U + 0D4D)
4.Type (U + 0D35)
  
Actual results:
For the three cases, we have the respective conjunct being substitued.

Expected results:
It should be in such a way that, the conjuct must be substituted when necessary
in a word, else it must be in the key sequence.

Additional info:
Comment 7 Ani Peter 2006-05-25 07:43:43 EDT
Darshan,

Here, the CATEGORY-II problems are to be omitted. I have reported yesterday that
case (ii) is working fine . Same is case (i). Its also fine since the
combination must be 
 (U + 0D19) + (U + 0D4D) + (U + 0D15) (as in the present system)
and not
 (U + 0D28) + (U + 0D4D) + (U + 0D15).

Both these are confirmed and not needed to be corrected.
Comment 8 Leon Ho 2006-08-28 02:15:56 EDT
Please check fonts-malayalam-2.0.1-1 and latest pango for fixes. Can you confirm
what's left to fix?
Comment 9 Ani Peter 2006-08-31 06:44:43 EDT
Report after testing the above issue in the New font:

1. The below mentioned consonants when combined with (U+200d) and (U+0d33) is
working fine, that is proper glyh is being replaced.
U + 0D15
U + 0D2A
U + 0D17
U + 0D2C
U + 0D2E 
U + 0D36
U + 0D38
U + 0D39.

And with all other consonants, the result is key combination. Thus this is solved.

But when any consonant combined with (U+200d) and  (U+32), there is rendering issue.

ie, Any consonant + (U+200d) + (U+0d32) = the result must be just the same typed
letters in key sequence, but in the font the (U_200d) is appearing after the
(U+0d32) and hence its wrong.

Special case:
 The following combination was working correct in the previous font but wrong in
the new one.
ie, (U+0d32) + (U+200d) + (U+0d32). It must give another glyph but the output is
wrong in the new font.

Best regards
Ani
Comment 11 Ani Peter 2006-09-14 03:09:21 EDT
please refer comment #6, no solution is yet provided for the same
Ani
Comment 12 Ani Peter 2006-09-25 03:28:22 EDT
comment #6 discussed with Rahul. can be solved by using (U+200d)

Thanks
Ani
Comment 13 Satyabrata Maitra 2006-09-25 09:40:54 EDT
Ani or Rahul

Please inform if this bug is for all the gsub problems with 0D32 and 0D33?
Another bug has been created for that actually. Thatswhy need to know. Please
visit the bug 206431. This has been created for all the gsub problems in ml_IN.
So, are those the same bug? Pls inform.
Comment 14 Rahul Bhalerao 2006-09-26 18:09:35 EDT
Satya,
This bug was created for all the GSUB issues in ml_IN. Most of it were fixed in
the 2.0.1-1 and separate bugs were created for issues with 0d32, 0d33 and 0d31
etc. All other issues in this bug are solved. Later a similar bug was created
after the testing of 2.0.1-1. So the bug 206431 have same purpose. 

Since issues in this bug are resolved, can I mark it as MODIFIED?
Comment 15 Lawrence Lim 2006-09-27 08:25:51 EDT
RE Comment #14
Yes, that will be best.

Bug 206431 was created with the goal of identifying all the failures found in
the font TC deemed most important for the native users. The failures could be
caused by numerous factor, hence, new bugs should be created with patch attached
and link back to the placeholder such Bug 206431 so that it easy to track the
progress of the Bugs.

Thanks for all the work put in so far. :)
Comment 16 Rahul Bhalerao 2006-09-27 11:35:27 EDT
All the issues in this bug are fixed in the font release 2.0.1-1
Comment 17 Lawrence Lim 2006-09-28 23:07:36 EDT
Bug 206431 has been confirmed fixed. This is ready to resolve once the new
package is available.

FIXED!!!
Comment 18 A S Alam 2007-04-27 08:11:37 EDT
Mention bug is fixed with following release:
fonts-malayalam-2.1.5-1.fc7

Note You need to log in before you can comment on or make changes to this bug.