Bug 192815 - PPD options not available even though real PPD is
PPD options not available even though real PPD is
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-05-23 08:03 EDT by David Anderson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-30 06:37:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of double entry (plus a third for the manually imported PPD) (24.46 KB, image/png)
2006-05-24 16:16 EDT, David Anderson
no flags Details
Screenshot of correct driver chosen (33.57 KB, image/png)
2006-05-24 16:22 EDT, David Anderson
no flags Details
Lack of options (32.37 KB, image/png)
2006-05-24 16:24 EDT, David Anderson
no flags Details
options a-plenty (91.97 KB, image/png)
2006-05-24 17:25 EDT, Tim Waugh
no flags Details

  None (edit)
Description David Anderson 2006-05-23 08:03:54 EDT
See https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=177799 for context.

system-config-printer displays two entries "Color Laserjet 2550" in its list 
of "HP" printers; whichever I select, I only get the generic Postscript 
options in the relevant tab. If I import the PPD myself using s-c-n's relevant 
option, I then also get a "Color Laserjet 2550 (PPD)" entry which has all the 
options.

[root@shed exim]# rpm -q foomatic system-config-printer cups
foomatic-3.0.2-33.3
system-config-printer-0.6.151.7-1
cups-1.2.0-1.1

This is despite foomatic shipping with the proper vendor PPD 
in /usr/share/foomatic/db/source/PPD/HP/color_laser/HP_Color_LaserJet_2550.ppd.gz

I don't know how long this PPD has shipped with Fedora, but I set up this 
printer when I had Fedora Core 2 and again with 4 and it has never used it.
Comment 1 Tim Waugh 2006-05-24 13:03:44 EDT
Can't reproduce that here.  I get one entry, and it's the correct PPD file.

Two entries?  Can you attach a screenshot of that please?
Comment 2 David Anderson 2006-05-24 16:16:33 EDT
Created attachment 129964 [details]
Screenshot of double entry (plus a third for the manually imported PPD)

Here it is - the "Really, I'm not mad!" screenshot! :-)
Comment 3 David Anderson 2006-05-24 16:22:05 EDT
Created attachment 129965 [details]
Screenshot of correct driver chosen

Argh, I am mad! Oh, I wish I could read. OK, there's only one entry for 2550
there. Here's a new screenshot showing I chose the 2550. Next screenshot will
show that it's not showing the options.
Comment 4 David Anderson 2006-05-24 16:24:00 EDT
Created attachment 129966 [details]
Lack of options

Here's a screenshot showing that the special driver options aren't made
available.
Comment 5 Tim Waugh 2006-05-24 17:24:27 EDT
Oh, I see now.  The issue here is that we build the options screen from the
foomatic XML, which unfortunately is hugely out of step with the actual PPD shipped.

If you peek at the PPD in /etc/cups/ppd/ you'll see that the correct PPD
actually is chosen.  Unfortunately there isn't a way to set the options not in
the XML and have them stick in Fedora Core 5.

The re-written system-config-printer in Fedora Core 6 builds the options screen
from the actual PPD (at last!).
Comment 6 Tim Waugh 2006-05-24 17:25:48 EDT
Created attachment 129970 [details]
options a-plenty

Here's a screenshot from the current Fedora Core development code.
Comment 7 David Anderson 2006-05-25 10:48:47 EDT
Roll on FC6 and keep up the good work!

I've now verified that KDE presents all the real options from the PPD for use, 
even though s-c-p doesn't. That's good enough for me. KDE seems to remember 
all my options too.

Note You need to log in before you can comment on or make changes to this bug.