Bug 1928166 - pulseaudio-module-bluetooth is removed on gnome-bluetooth update
Summary: pulseaudio-module-bluetooth is removed on gnome-bluetooth update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-bluetooth
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-02-12 14:26 UTC by Tomas Popela
Modified: 2021-02-14 01:23 UTC (History)
3 users (show)

Fixed In Version: gnome-bluetooth-3.34.3-3.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-14 01:23:43 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomas Popela 2021-02-12 14:26:23 UTC
This is caused by the change in https://src.fedoraproject.org/rpms/gnome-bluetooth/c/d08bdb86daf9e5c55b74fc6603f7ae678efcfc63?branch=f33, but as nothing requires it anymore the package is removed leaving users with no support for bluetooth audio devices (reported against Silverblue in https://github.com/fedora-silverblue/issue-tracker/issues/127).

Comment 1 Kalev Lember 2021-02-12 14:31:47 UTC
My suggestion would be to revert the change in F33 to unbreak users systems. For F34/rawhide, maybe the best course would be to completely drop the requirement and rely on comps correctly pulling in pipewire (or pulseaudio if we end up reverting back to pulseaudio instead of pipewire for the F34 release).

Comment 2 Bastien Nocera 2021-02-12 17:08:14 UTC
The actual problems seem to be caused by pipewire's compat "Provides", so I've reverted this change in F33 and F34.

Comment 3 Fedora Update System 2021-02-12 17:16:05 UTC
FEDORA-2021-79cc14e5aa has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-79cc14e5aa

Comment 4 Fedora Update System 2021-02-13 01:39:22 UTC
FEDORA-2021-79cc14e5aa has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-79cc14e5aa`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-79cc14e5aa

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2021-02-14 01:23:43 UTC
FEDORA-2021-79cc14e5aa has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.