Bug 1928290 - libprojectM-3.1.11 is available
Summary: libprojectM-3.1.11 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libprojectM
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sergio Basto
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-02-12 21:35 UTC by Upstream Release Monitoring
Modified: 2021-03-08 20:16 UTC (History)
3 users (show)

Fixed In Version: libprojectM-3.1.12-1.fc33 libprojectM-3.1.12-1.fc32 libprojectM-3.1.12-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-01 17:02:04 UTC
Type: ---


Attachments (Terms of Use)
[patch] Update to 3.1.10 (#1928290) (1.16 KB, patch)
2021-02-12 21:35 UTC, Upstream Release Monitoring
no flags Details | Diff
[patch] Update to 3.1.11 (#1928290) (1.16 KB, patch)
2021-02-14 17:23 UTC, Upstream Release Monitoring
no flags Details | Diff

Description Upstream Release Monitoring 2021-02-12 21:35:39 UTC
Latest upstream release: 3.1.10
Current version/release in rawhide: 3.1.8-2.fc34
URL: https://github.com/projectM-visualizer/projectm

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from anitya: https://release-monitoring.org/project/9180/

Comment 1 Upstream Release Monitoring 2021-02-12 21:35:53 UTC
Created attachment 1756716 [details]
[patch] Update to 3.1.10 (#1928290)

Comment 2 Upstream Release Monitoring 2021-02-12 21:45:27 UTC
the-new-hotness/release-monitoring.org's scratch build of libprojectM-3.1.10-1.fc32.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=61845292

Comment 3 Upstream Release Monitoring 2021-02-14 17:23:30 UTC
Latest upstream release: 3.1.11
Current version/release in rawhide: 3.1.8-2.fc34
URL: https://github.com/projectM-visualizer/projectm

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from anitya: https://release-monitoring.org/project/9180/

Comment 4 Upstream Release Monitoring 2021-02-14 17:23:42 UTC
Created attachment 1756990 [details]
[patch] Update to 3.1.11 (#1928290)

Comment 5 Upstream Release Monitoring 2021-02-14 17:32:33 UTC
the-new-hotness/release-monitoring.org's scratch build of libprojectM-3.1.11-1.fc32.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=61939613

Comment 6 Fedora Update System 2021-02-16 20:05:16 UTC
FEDORA-2021-66a5c8d2f0 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-66a5c8d2f0

Comment 7 Fedora Update System 2021-02-16 20:05:35 UTC
FEDORA-EPEL-2021-c839e1d5a7 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-c839e1d5a7

Comment 8 Fedora Update System 2021-02-16 20:20:18 UTC
FEDORA-2021-8fddb89b04 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2021-8fddb89b04

Comment 9 Fedora Update System 2021-02-17 05:59:47 UTC
FEDORA-2021-66a5c8d2f0 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-66a5c8d2f0`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-66a5c8d2f0

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2021-02-17 06:03:07 UTC
FEDORA-2021-8fddb89b04 has been pushed to the Fedora 32 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-8fddb89b04`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-8fddb89b04

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2021-02-17 06:03:46 UTC
FEDORA-EPEL-2021-c839e1d5a7 has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-c839e1d5a7

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Karel Volný 2021-02-21 21:42:31 UTC
I am unable to rebuild qmmp with libprojectM-3.1.11-1.fc35.x86_64 the relevant error is:


In file included from /usr/include/libprojectM/projectM.hpp:83,
                 from /builddir/build/BUILD/qmmp-1.4.4/x86_64-redhat-linux-gnu/src/plugins/Visual/projectm/projectm_autogen/EWIEGA46WW/../../../../../../../src/plugins/Visual/projectm/projectmwrapper.h:25,
                 from /builddir/build/BUILD/qmmp-1.4.4/x86_64-redhat-linux-gnu/src/plugins/Visual/projectm/projectm_autogen/EWIEGA46WW/moc_projectmwrapper.cpp:10,
                 from /builddir/build/BUILD/qmmp-1.4.4/x86_64-redhat-linux-gnu/src/plugins/Visual/projectm/projectm_autogen/mocs_compilation.cpp:4:
/usr/include/libprojectM/Common.hpp:34:10: fatal error: Intrinsics.h: No such file or directory
   34 | #include "Intrinsics.h"
      |          ^~~~~~~~~~~~~~
compilation terminated.
gmake[2]: *** [src/plugins/Visual/projectm/CMakeFiles/projectm.dir/build.make:117: src/plugins/Visual/projectm/CMakeFiles/projectm.dir/projectm_autogen/mocs_compilation.cpp.o] Error 1
gmake[2]: Leaving directory '/builddir/build/BUILD/qmmp-1.4.4/x86_64-redhat-linux-gnu'
gmake[1]: *** [CMakeFiles/Makefile2:3092: src/plugins/Visual/projectm/CMakeFiles/projectm.dir/all] Error 2



... seems like upstream has coped with it just yesterday:

https://github.com/projectM-visualizer/projectm/commit/b3c3282eb00fae210e9499fa9d11bcfcccffbd96

Comment 13 Karel Volný 2021-02-21 21:49:53 UTC
FYI, I've just set negative karma on all the updates ... but as Bodhi says "The maintainer may push manually if they determine that the issue is not severe." ;-)

Comment 14 Karel Volný 2021-02-21 21:54:33 UTC
(In reply to Karel Volný from comment #12)
> ... seems like upstream has coped with it just yesterday:
> 
> https://github.com/projectM-visualizer/projectm/commit/
> b3c3282eb00fae210e9499fa9d11bcfcccffbd96

... and it already got into 3.1.12 release, so probably let's continue with bug #1931164

Comment 15 Sergio Basto 2021-02-21 23:10:09 UTC
done . libprojectM-3.1.12-1 send to F35 to F32 and el8

Comment 16 Fedora Update System 2021-02-22 00:33:14 UTC
FEDORA-2021-57a049d2ba has been pushed to the Fedora 32 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-57a049d2ba`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-57a049d2ba

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 17 Karel Volný 2021-02-22 22:21:19 UTC
thanks, this works - https://koji.fedoraproject.org/koji/taskinfo?taskID=62536117

Comment 18 Fedora Update System 2021-03-01 17:02:04 UTC
FEDORA-2021-1f2f86d430 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 19 Fedora Update System 2021-03-01 17:06:05 UTC
FEDORA-2021-57a049d2ba has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 20 Fedora Update System 2021-03-08 20:16:15 UTC
FEDORA-EPEL-2021-aef703d44c has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.