Bug 192850 - /var/log/mail is not owned by any package
/var/log/mail is not owned by any package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sendmail (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
David Lawrence
: EasyFix
Depends On:
Blocks: 195282
  Show dependency treegraph
 
Reported: 2006-05-23 12:18 EDT by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-19 06:04:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2006-05-23 12:18:23 EDT
Description of problem:
/var/log/mail is not owned by any package, but should be owned by sendmail,
as the sendmail rpm package is delivering its content.

Version-Release number of selected component (if applicable):
sendmail-8.13.6-1

How reproducible:
rpm -qf /var/log/mail

Expected results:
Please apply the following patch (or better):

--- snipp ---
--- sendmail.spec       2006-03-25 21:29:02.000000000 +0100
+++ sendmail.spec.rsc   2006-05-23 18:22:57.000000000 +0200
@@ -533,6 +533,7 @@
 %attr(0644,root,root) %ghost   /etc/aliases.db
 %attr(0770,smmsp,smmsp) %dir   /var/spool/clientmqueue
 %attr(0700,root,mail) %dir     /var/spool/mqueue
+%dir %{stdir}
 %dir /etc/smrsh
 %dir /etc/mail

--- snapp ---
Comment 1 Robert Scheck 2006-06-20 09:34:11 EDT
Ping? Is there a special reason, that this report wasn't resolved?
Comment 2 Jiri TRAVNICEK, alias JITR {temporarily not reading bugmail} 2006-07-06 14:00:06 EDT
Well, also the RHEL 4's latest sendmail package (`sendmail-8.13.1-3.RHEL4.5')
has this problem.

As far as I understand the things, it might be better to file this bug against
RHEL as the RHEL seems to have a bit higher priority. In fact several bugfixes
make it to the Fedora due to them being fixed in RHEL. :-)

However this bug seems to be rather a minor one, which itself may have decreased
it's priority...
Comment 3 Thomas Woerner 2006-07-19 06:04:33 EDT
Fixed in rawhide in rpm sendmail-8.13.7-3 or newer.

Note You need to log in before you can comment on or make changes to this bug.