Bug 1928679 - [rebase] rebase sos to 4.1
Summary: [rebase] rebase sos to 4.1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: sos
Version: ---
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Pavel Moravec
QA Contact: Miroslav Hradílek
Jana Heves
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-02-15 11:09 UTC by Pavel Moravec
Modified: 2021-11-10 07:40 UTC (History)
7 users (show)

Fixed In Version: sos-4.1-1.el8
Doc Type: Enhancement
Doc Text:
.`sos` rebased to version 4.1 The `sos` package has been upgraded to version 4.1, which provides multiple bug fixes and enhancements. Notable enhancements include: * Red Hat Update Infrastructure (`RHUI`) plugin is now natively implemented in the `sos` package. With the `rhui-debug.py` python binary, `sos` can collect reports from `RHUI` including, for example, the main configuration file, the `rhui-manager` log file, or the installation configuration. * `sos` introduces the `--cmd-timeout` global option that sets manually a timeout for a command execution. The default value (-1) defers to the general command timeout, which is 300 seconds.
Clone Of:
Environment:
Last Closed: 2021-11-09 19:36:07 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2021:4388 0 None None None 2021-11-09 19:36:22 UTC

Description Pavel Moravec 2021-02-15 11:09:37 UTC
Description of problem:
RHEL8.5 should ship sos rebased to upstream version 4.1 (potentially to 4.2 if further agreed / depending on timing).

Rationale for the rebase: any backport work will be much easier and "testing distance" between upstream and downstream will be smaller.


Version-Release number of selected component (if applicable):
sos-4.0-*


How reproducible:
100%


Steps to Reproduce:
1. rpm -q sos


Actual results:
sos-4.0-*


Expected results:
sos-4.1-* or higher


Additional info:

Comment 3 Miroslav Hradílek 2021-04-30 14:34:39 UTC
Verified manually on RHEL-8.3.0 x86_64.

Old (unreleased):
====
# rpm -q sos
sos-4.0-11.el8.noarch

# sos report 

sosreport (version 4.0
. . .

# sos collect

sos-collector (version 4.0)
. . .

# sos clean /var/tmp/sosreport-hostname-twhtbmm.tar.xz

sos clean (version 4.0)
. . .

New:
====
# rpm -q sos
sos-4.1-1.el8.noarch

# sos report

sosreport (version 4.1)
. . .

# sos collect

sos-collector (version 4.1)
. . .

# sos clean /var/tmp/sosreport-hostname-twhtbmm.tar.xz

sos clean (version 4.1)
. . .

Comment 6 errata-xmlrpc 2021-11-09 19:36:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (sos bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2021:4388


Note You need to log in before you can comment on or make changes to this bug.