Bug 192880 - cups has wrong groups after an update
cups has wrong groups after an update
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-05-23 15:22 EDT by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.2.1-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-01 11:55:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2006-05-23 15:22:45 EDT
Description of problem:

Checking installation integrity results in this:

# rpm -V cups | grep G
......G.    /etc/cups
......GT  c /etc/cups/cupsd.conf
......G.    /etc/cups/ppd
S.5...GT  c /etc/cups/printers.conf
......G.    /etc/cups/ssl
......G.    /var/spool/cups
......G.    /var/spool/cups/tmp

Closer examination shows that in rpm package for things above their
group is set to 'nobody' but it used to be 'lp' and it stays that way.

Does that matter, appart from complaints from 'rpm -V', and if it
does not then why it was changed?  Maybe %post should take care of that?

Version-Release number of selected component (if applicable):
cups-1.2.1-2
Comment 1 Tim Waugh 2006-05-24 04:11:09 EDT
The groups should be correct for the configuration file shipped in the RPM.

If you've upgraded, I expect you'll be using the configuration file from 1.1.23.

Another possibility is that KDE has changed the configuration in some way.

Could you please attach your /etc/cups/cupsd.conf file?
Comment 2 Michal Jaegermann 2006-05-24 12:39:20 EDT
> If you've upgraded, I expect you'll be using the configuration file from
> 1.1.23.

This is not an issue.  Look again at the quoted ouput of 'rpm -V cups'.

......GT  c /etc/cups/cupsd.conf

In other words size, checksum and everything else but group and time-stamp
are exactly like what is in cups-1.2.1-2 package.  Also at this moment
files /etc/cups/cupsd.conf and /etc/cups/cupsd.conf.default do not differ.
The only difference is that /etc/cups/cupsd.conf was there before and after
an upgrade it retains its previous group ownership, i.e. 'lp', while
/etc/cups/cupsd.conf.default is a new one so it got unpacked with group
'nobody'.  It looks like that this is the way 'rpm' works so if this
needs to be corrected then it requires some intervention.  In case
of an installation "from scratch" the issue will not arise.

> Could you please attach your /etc/cups/cupsd.conf file?

Again, its content is precisly like /etc/cups/cupsd.conf.default and
the only thing about ownership of anything is

# Administrator user group...
SystemGroup sys root

This is not the problem.
Comment 3 Michal Jaegermann 2006-05-24 13:00:38 EDT
Well, the issue (if this is really an issue and I am not sure about
that but why this change) just got repeated in an update for FC5.
Comment 4 Tim Waugh 2006-05-24 13:34:37 EDT
Hmm, I synced all the ownerships during the 1.2rc phase.  Maybe something's
changed upstream again since then(!).
Comment 5 Michal Jaegermann 2006-05-24 14:10:25 EDT
Yes; but rpm does not apply ownership changes, or at least not in every
case, to files/directories which are already on disk.  Hence these "G"s
in an output of 'rpm -V'.

Once again - do we really care?  Here I do not know the answer.
Printing still works but maybe this has some security ramifications?
OTOH on production systems I prefer an output of 'rpm -V ...' to be
as quiet as possible.
Comment 6 Tim Waugh 2006-06-01 11:55:04 EDT
Fixed in 1.2.1-5.
Comment 7 Tim Waugh 2006-06-08 06:52:06 EDT
This should be fixed in the test update 1.2.1-1.7:

  https://www.redhat.com/archives/fedora-test-list/2006-June/msg00081.html

Note You need to log in before you can comment on or make changes to this bug.