Bug 1928847 (CVE-2021-20253) - CVE-2021-20253 ansible-tower: Privilege escalation via job isolation escape
Summary: CVE-2021-20253 ansible-tower: Privilege escalation via job isolation escape
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2021-20253
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1931431 1931432 1931961
Blocks: 1928848 1930769
TreeView+ depends on / blocked
 
Reported: 2021-02-15 16:21 UTC by Pedro Sampaio
Modified: 2021-03-24 08:38 UTC (History)
17 users (show)

Fixed In Version: ansible-tower 3.8.2, ansible-tower 3.7.5, ansible-tower 3.6.7
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in ansible-tower. The default installation is vulnerable to Job Isolation escape allowing an attacker to elevate the privilege from a low privileged user to the awx user from outside the isolated environment. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Clone Of:
Environment:
Last Closed: 2021-03-09 21:06:07 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2021:0778 0 None None None 2021-03-09 15:52:31 UTC
Red Hat Product Errata RHSA-2021:0779 0 None None None 2021-03-09 15:51:46 UTC
Red Hat Product Errata RHSA-2021:0780 0 None None None 2021-03-09 16:02:27 UTC

Description Pedro Sampaio 2021-02-15 16:21:27 UTC
A flaw was found in ansible tower. Default installations are vulnerable to “Job Isolation” Escapes that allows an attacker to elevate to the “awx” user from outside the isolated environment.

Comment 6 Borja Tarraso 2021-03-09 08:47:26 UTC
Acknowledgments:

Name: Matei Mal Badanoiu (Deloitte Romania)

Comment 7 errata-xmlrpc 2021-03-09 15:51:44 UTC
This issue has been addressed in the following products:

  Red Hat Ansible Tower 3.7 for RHEL 7

Via RHSA-2021:0779 https://access.redhat.com/errata/RHSA-2021:0779

Comment 8 errata-xmlrpc 2021-03-09 15:52:30 UTC
This issue has been addressed in the following products:

  Red Hat Ansible Tower 3.6 for RHEL 7

Via RHSA-2021:0778 https://access.redhat.com/errata/RHSA-2021:0778

Comment 9 errata-xmlrpc 2021-03-09 16:02:26 UTC
This issue has been addressed in the following products:

  Red Hat Ansible Tower 3.8 for RHEL 7

Via RHSA-2021:0780 https://access.redhat.com/errata/RHSA-2021:0780

Comment 10 Product Security DevOps Team 2021-03-09 21:06:07 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2021-20253

Comment 11 Tapas Jena 2021-03-24 08:38:03 UTC
Mitigation:

Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.


Note You need to log in before you can comment on or make changes to this bug.