Bug 192885 - i810 driver on i945 hardware causes kernel panic when X server terminates
i810 driver on i945 hardware causes kernel panic when X server terminates
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-23 15:48 EDT by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-25 09:04:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2006-05-23 15:48:28 EDT
Description of problem:

i810 driver on i945 hardware causes kernel panic when X server terminates.  It
also causes a kernel panic when entering "graphics mode" while booting, but that
can be worked around by booting into runlevel 3 and manually entering runlevel 5
after boot.  This problem did not exist in FC4 but has been a problem with all
released FC5 kernels (including the current one, 2.6.16-1.2122_FC5).  Note that
I was using x86 FC4, but I am now using x86_64 FC5.


Version-Release number of selected component (if applicable):

1.4.1.3-3.1


How reproducible:

every time


Steps to Reproduce:
1. Install FC5 on Dell OptiPlex GX620 with integrated Intel Graphic Media
Accelerator 950
2. configure FC5 to use i810 video driver
3. boot into runlevel 3
4. manually enter runlevel 5
5. after verifying proper operation of video in runlevel 5, attempt to enter
runlevel 3
  
Actual results:

System hangs with the following information in the system log:

May 10 18:13:42 patience init: Switching to runlevel: 3
May 10 18:13:49 patience shutdown[2220]: shutting down for system reboot
May 10 18:14:16 patience init: Switching to runlevel: 6
May 10 18:14:30 patience kernel: Unable to handle kernel paging request at
ffff81002d56f8e0 RIP: 
May 10 18:14:30 patience kernel: <ffffffff801213db>{global_flush_tlb+118}
May 10 18:14:30 patience kernel: PGD 8063 PUD 9063 PMD 800000002d4001e3 BAD
May 10 18:14:30 patience kernel: Oops: 0009 [1] SMP 
May 10 18:14:30 patience kernel: last sysfs file:
/class/net/sit0/statistics/collisions
May 10 18:14:30 patience kernel: CPU 0 
May 10 18:14:30 patience kernel: Modules linked in: loop i915 drm ipv6 ppdev
autofs4 hidp l2cap bluetooth sunrpc ip_conntrack_netbios_ns ipt_REJECT xt_state
ip_conntrack nfnetlink xt_tcpudp iptable_filter ip_tables x_tables vfat fat
nls_utf8 ntfs(U) dm_mirror dm_mod video button battery ac lp parport nvram
snd_intel8x0 snd_ac97_codec snd_ac97_bus snd_seq_dummy snd_seq_oss
snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss uhci_hcd
snd_pcm ehci_hcd snd_timer sg snd soundcore tg3 snd_page_alloc hw_random
i2c_i801 i2c_core ext3 jbd ata_piix libata sd_mod scsi_mod
May 10 18:14:30 patience kernel: Pid: 2744, comm: Xorg Tainted: P     
2.6.16-1.2111_FC5 #1
May 10 18:14:30 patience kernel: RIP: 0010:[<ffffffff801213db>]
<ffffffff801213db>{global_flush_tlb+118}
May 10 18:14:30 patience kernel: RSP: 0018:ffff810031dcfe88  EFLAGS: 00010282
May 10 18:14:30 patience kernel: RAX: 0000000000000000 RBX: ffff81002d56f8e0
RCX: 000000000000003f
May 10 18:14:30 patience kernel: RDX: ffff81003c743a80 RSI: 0000000000000001
RDI: ffff810001f1d0c0
May 10 18:14:30 patience kernel: RBP: ffff81002d56f8e0 R08: ffff810031dcfd68
R09: 0000000000000003
May 10 18:14:30 patience kernel: R10: 0000000000000002 R11: 0000000000000003
R12: ffff810031752a40
May 10 18:14:30 patience kernel: R13: ffff81003c743a00 R14: ffff8100310cb300
R15: ffff81003d125500
May 10 18:14:30 patience kernel: FS:  00002aaaaaad7340(0000)
GS:ffffffff8050c000(0000) knlGS:0000000000000000
May 10 18:14:31 patience kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
May 10 18:14:31 patience kernel: CR2: ffff81002d400b78 CR3: 000000003127a000
CR4: 00000000000006e0
May 10 18:14:31 patience kernel: Process Xorg (pid: 2744, threadinfo
ffff810031dce000, task ffff8100022a5860)
May 10 18:14:32 patience kernel: Stack: 0000000000000008 ffff81003c969440
0000000000002823 ffffffff8025e21f 
May 10 18:14:32 patience kernel:        0000000000000000 ffff81003c789540
ffff8100310cb300 ffffffff8025d704 
May 10 18:14:32 patience kernel:        0000000000000008 ffff8100310cb300 
May 10 18:14:32 patience kernel: Call Trace: <ffffffff8025e21f>{agp_free_memory+112}
May 10 18:14:32 patience kernel:        <ffffffff8025d704>{agp_release+159}
<ffffffff8017f80a>{__fput+184}
May 10 18:14:32 patience kernel:        <ffffffff8017ced6>{filp_close+89}
<ffffffff8017e3a5>{sys_close+143}
May 10 18:14:33 patience kernel:        <ffffffff8010a7ba>{system_call+126}
May 10 18:14:33 patience kernel: 
May 10 18:14:33 patience kernel: Code: 48 8b 2b 48 8b 7b 08 48 85 ff 74 07 31 f6
e8 72 e4 03 00 48 
May 10 18:14:33 patience kernel: RIP <ffffffff801213db>{global_flush_tlb+118}
RSP <ffff810031dcfe88>
May 10 18:14:33 patience kernel: CR2: ffff81002d56f8e0
May 10 18:14:33 patience kernel:  <1>Unable to handle kernel paging request at
ffff81002d5f13f8 RIP: 
May 10 18:14:33 patience kernel: <ffffffff80167513>{unmap_vmas+761}
May 10 18:14:33 patience kernel: PGD 8063 PUD 9063 PMD 800000002d4001e3 BAD
May 10 18:14:33 patience kernel: Oops: 0009 [2] SMP 
May 10 18:14:33 patience kernel: last sysfs file:
/class/net/sit0/statistics/collisions
May 10 18:14:33 patience kernel: CPU 0 
May 10 18:14:33 patience kernel: Modules linked in: loop i915 drm ipv6 ppdev
autofs4 hidp l2cap bluetooth sunrpc ip_conntrack_netbios_ns ipt_REJECT xt_state
ip_conntrack nfnetlink xt_tcpudp iptable_filter ip_tables x_tables vfat fat
nls_utf8 ntfs(U) dm_mirror dm_mod video button battery ac lp parport nvram
snd_intel8x0 snd_ac97_codec snd_ac97_bus snd_seq_dummy snd_seq_oss
snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss uhci_hcd
snd_pcm ehci_hcd snd_timer sg snd soundcore tg3 snd_page_alloc hw_random
i2c_i801 i2c_core ext3 jbd ata_piix libata sd_mod scsi_mod
May 10 18:14:33 patience kernel: Pid: 2744, comm: Xorg Tainted: P     
2.6.16-1.2111_FC5 #1
May 10 18:14:33 patience kernel: RIP: 0010:[<ffffffff80167513>]
<ffffffff80167513>{unmap_vmas+761}
May 10 18:14:34 patience kernel: RSP: 0018:ffff810031dcfb88  EFLAGS: 00010202
May 10 18:14:34 patience kernel: RAX: ffff8100022a5860 RBX: 0000000000000000
RCX: ffff810031d50f20
May 10 18:14:34 patience kernel: RDX: 00000000ffffffff RSI: 00000000000bf067
RDI: ffff810001b57c50
May 10 18:14:34 patience kernel: RBP: 0000000038015020 R08: 000000000000c418
R09: ffff810001d94540
May 10 18:14:34 patience kernel: R10: ffff8100013b1fc0 R11: 0000000038015020
R12: 00002aaabc87f000
May 10 18:14:34 patience kernel: R13: ffff81002d5f13f8 R14: 00002aaabc889000
R15: ffff810001fe9400
May 10 18:14:34 patience kernel: FS:  00002aaaaaad7340(0000)
GS:ffffffff8050c000(0000) knlGS:0000000000000000
May 10 18:14:34 patience kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
May 10 18:14:34 patience kernel: CR2: ffff81002d400f88 CR3: 0000000000101000
CR4: 00000000000006e0
May 10 18:14:34 patience kernel: Process Xorg (pid: 2744, threadinfo
ffff810031dce000, task ffff8100022a5860)
May 10 18:14:34 patience kernel: Stack: 0000000000000000 ffff810031dcfc58
ffffffffffffffff 0000000000000000 
May 10 18:14:34 patience kernel:        ffff810031289140 ffff810031dcfc60
0000000000396bb6 0000000000000000 
May 10 18:14:34 patience kernel:        00000001022a5a98 00002aaabc889000 
May 10 18:14:34 patience kernel: Call Trace: <ffffffff8016ae93>{exit_mmap+120}
<ffffffff8012fa60>{mmput+37}
May 10 18:14:35 patience kernel:        <ffffffff80135b21>{do_exit+574}
<ffffffff8033d42c>{do_page_fault+1760}
May 10 18:14:35 patience kernel:        <ffffffff80202e12>{find_next_bit+89}
<ffffffff8010b6f9>{error_exit+0}
May 10 18:14:35 patience kernel:        <ffffffff801213db>{global_flush_tlb+118}
<ffffffff801213f6>{global_flush_tlb+145}
May 10 18:14:35 patience kernel:        <ffffffff8025e21f>{agp_free_memory+112}
<ffffffff8025d704>{agp_release+159}
May 10 18:14:35 patience kernel:        <ffffffff8017f80a>{__fput+184}
<ffffffff8017ced6>{filp_close+89}
May 10 18:14:35 patience kernel:        <ffffffff8017e3a5>{sys_close+143}
<ffffffff8010a7ba>{system_call+126}
May 10 18:14:35 patience kernel: 
May 10 18:14:35 patience kernel: Code: 49 8b 55 00 48 85 d2 75 0a 48 ff 4c 24 30
e9 ab 01 00 00 48 
May 10 18:14:35 patience kernel: RIP <ffffffff80167513>{unmap_vmas+761} RSP
<ffff810031dcfb88>
May 10 18:14:35 patience kernel: CR2: ffff81002d5f13f8
May 10 18:14:35 patience kernel:  <1>Fixing recursive fault but reboot is needed!
May 10 18:14:35 patience kernel: Unable to handle kernel paging request at
ffff81002d56f248 RIP: 
May 10 18:14:35 patience kernel: <ffffffff80190e22>{do_sys_poll+319}
May 10 18:14:35 patience kernel: PGD 8063 PUD 9063 PMD 800000002d4001e3 BAD
May 10 18:14:35 patience kernel: Oops: 0009 [3] SMP 
May 10 18:14:35 patience kernel: last sysfs file:
/class/net/sit0/statistics/collisions
May 10 18:14:35 patience kernel: CPU 1 
May 10 18:14:35 patience kernel: Modules linked in: loop i915 drm ipv6 ppdev
autofs4 hidp l2cap bluetooth sunrpc ip_conntrack_netbios_ns ipt_REJECT xt_state
ip_conntrack nfnetlink xt_tcpudp iptable_filter ip_tables x_tables vfat fat
nls_utf8 ntfs(U) dm_mirror dm_mod video button battery ac lp parport nvram
snd_intel8x0 snd_ac97_codec snd_ac97_bus snd_seq_dummy snd_seq_oss
snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss uhci_hcd
snd_pcm ehci_hcd snd_timer sg snd soundcore tg3 snd_page_alloc hw_random
i2c_i801 i2c_core ext3 jbd ata_piix libata sd_mod scsi_mod
May 10 18:14:35 patience kernel: Pid: 24344, comm: evolution Tainted: P     
2.6.16-1.2111_FC5 #1
May 10 18:14:35 patience kernel: RIP: 0010:[<ffffffff80190e22>]
<ffffffff80190e22>{do_sys_poll+319}
May 10 18:14:35 patience kernel: RSP: 0018:ffff810023dbbed8  EFLAGS: 00010282
May 10 18:14:35 patience kernel: RAX: 0000000000000000 RBX: ffff81002d56f24c
RCX: 0000000000000001
May 10 18:14:35 patience kernel: RDX: ffff81003d133080 RSI: 0000000000000282
RDI: ffff810001ff3c80
May 10 18:14:35 patience kernel: RBP: 0000000000000000 R08: ffff810023dba000
R09: ffff81001ac2fbc0
May 10 18:14:35 patience kernel: R10: ffff8100021d9c08 R11: ffffffff80339af6
R12: ffff81002d56f240
May 10 18:14:35 patience kernel: R13: ffff81002d56f248 R14: ffff810023dbbf78
R15: 0000000000000000
May 10 18:14:35 patience kernel: FS:  0000000043204950(0063)
GS:ffff8100021d3ec0(0000) knlGS:0000000000000000
May 10 18:14:35 patience kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
May 10 18:14:35 patience kernel: CR2: ffff81002d400b78 CR3: 000000000ed04000
CR4: 00000000000006e0
May 10 18:14:35 patience kernel: Process evolution (pid: 24344, threadinfo
ffff810023dba000, task ffff81003d133080)
May 10 18:14:35 patience kernel: Stack: ffff81003f61cc40 0000000000d5d2e0
ffff81002d56f240 0000000000000000 
May 10 18:14:35 patience kernel:        ffff81002d56f24c 0000000100000001
ffffffff801904af ffff81001f4e4000 
May 10 18:14:35 patience kernel:        0000000000000000 00002aaab691a494 
May 10 18:14:35 patience kernel: Call Trace: <ffffffff801904af>{__pollwait+0}
<ffffffff8019104b>{sys_poll+58}
May 10 18:14:35 patience kernel:        <ffffffff8010a7ba>{system_call+126}
May 10 18:14:35 patience kernel: 
May 10 18:14:35 patience kernel: Code: 41 8b 5c 24 08 89 5c 24 2c c7 44 24 28 00
00 00 00 4d 89 e5 
May 10 18:14:35 patience kernel: RIP <ffffffff80190e22>{do_sys_poll+319} RSP
<ffff810023dbbed8>
May 10 18:14:35 patience kernel: CR2: ffff81002d56f248
May 10 18:14:36 patience smartd[2208]: smartd received signal 15: Terminated 
May 10 18:14:36 patience smartd[2208]: smartd is exiting (exit status 0) 
May 10 18:14:37 patience xinetd[2313]: Exiting...
May 10 18:14:40 patience kernel:  <1>Unable to handle kernel paging request at
ffff81002d56f368 RIP: 
May 10 18:14:40 patience kernel: <ffffffff80190e22>{do_sys_poll+319}
May 10 18:14:40 patience kernel: PGD 8063 PUD 9063 PMD 800000002d4001e3 BAD
May 10 18:14:40 patience kernel: Oops: 0009 [4] SMP 
May 10 18:14:40 patience kernel: last sysfs file:
/class/net/sit0/statistics/collisions
May 10 18:14:40 patience kernel: CPU 0 
May 10 18:14:40 patience kernel: Modules linked in: loop i915 drm ipv6 ppdev
autofs4 hidp l2cap bluetooth sunrpc ip_conntrack_netbios_ns ipt_REJECT xt_state
ip_conntrack nfnetlink xt_tcpudp iptable_filter ip_tables x_tables vfat fat
nls_utf8 ntfs(U) dm_mirror dm_mod video button battery ac lp parport nvram
snd_intel8x0 snd_ac97_codec snd_ac97_bus snd_seq_dummy snd_seq_oss
snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss uhci_hcd
snd_pcm ehci_hcd snd_timer sg snd soundcore tg3 snd_page_alloc hw_random
i2c_i801 i2c_core ext3 jbd ata_piix libata sd_mod scsi_mod
May 10 18:14:40 patience kernel: Pid: 24314, comm: evolution-data- Tainted: P  
   2.6.16-1.2111_FC5 #1
May 10 18:14:40 patience kernel: RIP: 0010:[<ffffffff80190e22>]
<ffffffff80190e22>{do_sys_poll+319}
May 10 18:14:40 patience kernel: RSP: 0018:ffff8100227e1ed8  EFLAGS: 00010286
May 10 18:14:40 patience kernel: RAX: 0000000000000000 RBX: ffff81002d56f36c
RCX: ffff810001fedd00
May 10 18:14:40 patience kernel: RDX: ffff81003b7cd040 RSI: 0000000000000282
RDI: ffff810001ff3c80
May 10 18:14:40 patience kernel: RBP: 0000000000000000 R08: ffff8100227e0000
R09: ffff81001ac2f440
May 10 18:14:40 patience kernel: R10: 000000000000000f R11: ffffffff80339af6
R12: ffff81002d56f360
May 10 18:14:40 patience kernel: R13: ffff81002d56f368 R14: ffff8100227e1f78
R15: 0000000000000000
May 10 18:14:40 patience kernel: FS:  0000000042844950(0063)
GS:ffffffff8050c000(0000) knlGS:0000000000000000
May 10 18:14:40 patience kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
May 10 18:14:40 patience kernel: CR2: ffff81002d400b78 CR3: 00000000271d6000
CR4: 00000000000006e0
May 10 18:14:40 patience kernel: Process evolution-data- (pid: 24314, threadinfo
ffff8100227e0000, task ffff81003b7cd040)
May 10 18:14:40 patience kernel: Stack: ffff81003d308ea8 0000000000550ad0
ffff81002d56f360 0000000000000000 
May 10 18:14:40 patience kernel:        ffff81002d56f36c 0000000100000001
ffffffff801904af ffff810022133000 
May 10 18:14:40 patience ntpd[2325]: ntpd exiting on signal 15
May 10 18:14:40 patience kernel:        0000000000000000 000000000051bf50 
May 10 18:14:40 patience kernel: Call Trace: <ffffffff801904af>{__pollwait+0}
<ffffffff8019104b>{sys_poll+58}
May 10 18:14:40 patience kernel:        <ffffffff8010a7ba>{system_call+126}
May 10 18:14:40 patience kernel: 
May 10 18:14:40 patience kernel: Code: 41 8b 5c 24 08 89 5c 24 2c c7 44 24 28 00
00 00 00 4d 89 e5 
May 10 18:14:40 patience kernel: RIP <ffffffff80190e22>{do_sys_poll+319} RSP
<ffff8100227e1ed8>
May 10 18:14:40 patience kernel: CR2: ffff81002d56f368
May 10 18:15:45 patience syslogd 1.4.1: restart.


Expected results:

System gracefully enters runlevel 3


Additional info:

This same error occurs if I choose "logout" from Metacity, but that usually
hangs before messages are logged to the syslog.

I didn't try any of the test kernels for FC5, so I don't know how long this has
been a problem.  It has been a problem since day 1 of FC5 "released", however. 
The system seems to work reliably if I use the VESA driver, however I give up
accelerated graphics with VESA (as sad as the graphics acceleration is on this
chipset, it is still preferable to nothing).  This may be x86_64 related.


I will provide more specific hardware and system information as requested.
Comment 1 Need Real Name 2006-05-24 18:27:21 EDT
Note - this may be a duplicate of 186321
Comment 2 jonathan baron 2006-05-24 19:45:08 EDT
I had the same problem.  I think it got a bit better when I
installed a more recent version of the i810 driver.  (I'm sorry,
but I forgot where I got it, probably the development repository
of Fedora.)  But it still crashes on logout or even killall,
which means that it is impossible to test changes to xorg.conf
without rebooting.  So I too am using the vesa driver.

Both drivers say that they are doing 1920x1200 resolution
according to xdypinfo, and the resolution looks correct, but
they both cut off the display at 1600x1200, so that, for
example, the word Fedora in the Gnome login screen is cut off
at the "a".  (This is another problem, which may be subject to
a workaround, so I am not yet reporting a bug.)

Comment 3 Mike A. Harris 2006-05-25 09:04:34 EDT
Your kernel is tainted by a proprietary kernel module.

Closing bug "CANTFIX" (we do not support systems with 3rd party kernel modules)

Note You need to log in before you can comment on or make changes to this bug.