Bug 19289 - wrong libraries are dynamically linked into the compat-binutils
wrong libraries are dynamically linked into the compat-binutils
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: compat-binutils (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-17 18:16 EDT by Ronald Cole
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-17 18:16:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronald Cole 2000-10-17 18:16:27 EDT
LD_LIBRARY_PATH is set in /usr/i386-glibc20-linux/bin/wrapper to a
nonexistant directory.

Here's a patch:

--- wrapper~	Mon Apr 19 02:35:10 1999
+++ wrapper	Tue Oct 17 15:13:42 2000
@@ -2,5 +2,5 @@
 LibDirectory=/usr/i386-glibc20-linux/lib
 if [ -x $0.real ] ; then
-    export LD_LIBRARY_PATH=/usr/i386-glibc20/lib
+    export LD_LIBRARY_PATH=$LibDirectory
     exec $LibDirectory/ld-linux.so.2 $0.real $*
 else
Comment 1 Jakub Jelinek 2000-10-20 08:34:18 EDT
Yes, it is bug, but in my eyes not worth making an errata because of it.
Not too many people use the wrapper script and it is no longer present in
7.0 distribution.

Note You need to log in before you can comment on or make changes to this bug.