Bug 192893 - scim-qtimm: kde apps crash
scim-qtimm: kde apps crash
Status: CLOSED DUPLICATE of bug 192471
Product: Fedora
Classification: Fedora
Component: scim-qtimm (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-23 16:47 EDT by Hesty
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-06 06:20:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hesty 2006-05-23 16:47:17 EDT
Description of problem:
Ever since upgrading to the new KDE, kmymoney crashes on shutdown.

Version-Release number of selected component (if applicable):
kdebase-3.5.2-0.4.fc5
kdelibs-3.5.2-0.2.fc5
kmymoney2-0.8.4-1.fc5

How reproducible:
Always

Steps to Reproduce:
1. Start kmymoney.
2. Shutdown kmymoney by clicking "X".
  
Actual results:
kmymoney crashes.

Expected results:
kmymoney shutdown nicely.

Additional info:
Could also be caused by problem with scim. Here are the output to terminal prior
to crashes:
$ kmymoney
kbuildsycoca running...
Reusing existing ksycoca
ScimInputContextPlugin()
KCrash: Application 'kmymoney' crashing...
Comment 1 Ngo Than 2006-05-24 03:46:43 EDT
You should remove libstdc++so7 and scim-qtimm packages and try again. It seems
scim-qtimm is the cause for several KDE crashes 
Comment 2 Rex Dieter 2006-05-24 08:00:41 EDT
I can confirm scim-qtimm seems problematic, for me.  Without it installed,
kmymoney runs fine.  With it, kmymoney crashes immediately on launch:

$ kmymoney
ScimInputContextPlugin()
~ScimImputContextPlugin()
KCrash: Application 'kmymoney' crashing...
Comment 3 Rex Dieter 2006-05-24 08:04:07 EDT
I would speculate it has something to do with scim-libs using libstdc++-*.so.7
and scim-qtimm (and qt/kde) using libstdc++.so.6.
Comment 4 Rex Dieter 2006-06-05 14:05:51 EDT
Reassigning to scim, (almost) every kde app I try crashes when scim-qtimm is
installed.
Comment 5 Rex Dieter 2006-06-05 14:07:10 EDT
Reassigning to scim-qtimm, (almost) every kde app I try crashes when scim-qtimm
is installed.
Comment 6 Jens Petersen 2006-06-06 06:20:29 EDT

*** This bug has been marked as a duplicate of 192471 ***

Note You need to log in before you can comment on or make changes to this bug.