Bug 192923 - haldaemon causes autofs mounts to be constantly remounted
haldaemon causes autofs mounts to be constantly remounted
Status: CLOSED DUPLICATE of bug 191863
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-24 05:22 EDT by Daniel Qarras
Modified: 2013-03-13 00:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-24 18:05:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Qarras 2006-05-24 05:22:06 EDT
Description of problem:
I use autofs to mount /home and /net in my intranet. It works all ok if
haldaemon is disabled, mount points are umounted after the configured autofs
timeout and mounted again when needed. So far so good.

But if I enable haldaemon, then after the mount points have been umounted after
the autofs timeout, they are immediately mounted again. This makes the autofs
timeout pretty much useless as the mount points are mounted all the time.

Version-Release number of selected component (if applicable):
FC5 with available updates.

How reproducible:
Always.

Steps to Reproduce:
1. Start haldaemon
2. Access some autofs mounted mount points
3. See server logs how mount points are then umounted/mounted endlessly
  
Actual results:
Constant umount/mount events.

Expected results:
Mount points mounted only when needed/accessed.

Additional info:
Might have some relevance with bug 191863. Turning off haldaemon is not very
feasible as I use GNOME / X on my laptop all the time.

I am able and willing to test possible experimental autofs RPMs that might be
made available.
Comment 1 Ian Kent 2006-05-24 08:08:21 EDT
(In reply to comment #0)
> Description of problem:
> I use autofs to mount /home and /net in my intranet. It works all ok if
> haldaemon is disabled, mount points are umounted after the configured autofs
> timeout and mounted again when needed. So far so good.
> 
> But if I enable haldaemon, then after the mount points have been umounted after
> the autofs timeout, they are immediately mounted again. This makes the autofs
> timeout pretty much useless as the mount points are mounted all the time.
> 

Yep. Right you are.

Ian
Comment 2 John (J5) Palmieri 2006-05-24 10:54:19 EDT
I have a fix going in soon.
Comment 3 John (J5) Palmieri 2006-05-24 18:05:57 EDT

*** This bug has been marked as a duplicate of 191863 ***

Note You need to log in before you can comment on or make changes to this bug.