Bug 192932 - Problems after upgrading to net-snmp-5.3.1.pre2-1
Problems after upgrading to net-snmp-5.3.1.pre2-1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: net-snmp (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-24 06:52 EDT by Reuben Farrelly
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 5.3.1.pre2-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-26 07:56:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Reuben Farrelly 2006-05-24 06:52:00 EDT
I've just updated to the latest rawhide versions of net-snmp - 5.3.1.pre2-1. 
This has unfortunately broken two things:

Firstly, /usr/include/net-snmp/net-snmp-config.h no longer exists.  This breaks
many auto* scripts at least on x86_64, the new include file is
/usr/include/net-snmp/net-snmp-config64.h
Adding a symlink as part of the postinstall may be a suitable workaround for
this, at least in the interim.  Otherwise lots of people are going to have to
edit scripts to get them to compile.

Secondly, with cactid, I have rebuilt the binary against the new files after
symlinking as above, but it will not run. It fails with this message:

[root@tornado cactid]# cactid
CACTID: Using cactid config file [/etc/cactid.conf]
CACTID: Version 0.8.6h starting
CACTID: ERROR: SNMP Library Version Mismatch (5.3.1.pre1 vs 5.3.1.pre2)

I don't know where the version 5.3.1.pre1 came from.....it was never a rawhide
package.

Downgrading to 5.3-8 resolved both of these issues.
Comment 1 Radek Vokal 2006-05-24 07:34:25 EDT
About the first issue. Due to multilib madness I decided to separate 64bit and
32bit specific files. The net-snmp-config.h is one of the, so I've moved it to
64.h. If you know better solution for this, let me know. I was thinking also
about creating 32.h and 64.h file and net-snmp-config.h will use some #ifdef to
recognize between those two. I can't say which approach is better. 

Will look at the second issue, looks really strange. 
Comment 2 Reuben Farrelly 2006-05-24 08:25:24 EDT
Personally I am x86_64 and I don't even have any i386 RPM's installed.  That way
the multilib stuff is not really a problem for me.  I'm just not sure that your
workaround is a good one, I can see there could be serious fallout if FC differs
from other systems in terms of the names of include files.
I wonder if it would be practical or possible to have only one OR the other
net-snmp-devel packages installed at once (still retain both archs of the other
packages), that way you could have the same filenames in both -devel packages
and not have this problem.


Comment 3 Radek Vokal 2006-05-24 10:21:04 EDT
Ok, the first issue should be fixed now in net-snmp-5.3.1.pre2-2.
net-snmp-config.h redirects to correct header file. The second issue - I guess
this happens because some library that cacti is using is not build against new
libnetsnmp (php-snmp?) so php will need to be rebuilt first. Check again after
php gets rebuilt. 
Comment 4 Reuben Farrelly 2006-05-26 04:17:17 EDT
Reopening - still having problems with a ghost version number 5.3.1.pre1 showing
up.  However your multilib fixes seem to be OK.

In /usr/include/net-snmp/net-snmp-config-x86_64.h we see:

/* Define to the full name and version of this package. */
#define PACKAGE_STRING "Net-SNMP 5.3.1.pre1"

and

/* Define to the version of this package. */
#define PACKAGE_VERSION "5.3.1.pre1"

I've changed both references by hand to pre2 and cactid compiles and works fine.
 Obviously this is a bug and needs to be fixed in rawhide (somehow).
Comment 5 Radek Vokal 2006-05-26 07:56:56 EDT
ok, give it please another chance with 5.3.1.pre2-4 :) 

Note You need to log in before you can comment on or make changes to this bug.