Bug 1929522 - python3-mypy-0.782-2.fc33 has outdated typeshed vendored
Summary: python3-mypy-0.782-2.fc33 has outdated typeshed vendored
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-typeshed
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1931044 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-02-17 05:03 UTC by Saif Hakim
Modified: 2021-03-19 19:55 UTC (History)
3 users (show)

Fixed In Version: python-typeshed-0.1-0.20210217git.fc33 python-typeshed-0.1-0.20210217git.fc32 python-typeshed-0.1-0.20191011git2.fc33 python-typeshed-0.1-0.20191011git2.fc32 python-typeshed-0.1-0.20191011git2.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-26 01:08:20 UTC
Type: Bug


Attachments (Terms of Use)
vendored hashlib types from python3-mypy (2.30 KB, text/plain)
2021-02-17 05:03 UTC, Saif Hakim
no flags Details

Description Saif Hakim 2021-02-17 05:03:06 UTC
Created attachment 1757457 [details]
vendored hashlib types from python3-mypy

Description of problem:
mypy==0.782 vendors python/typeshed@e199c2e via a git submodule, which can be confirmed here: https://github.com/python/mypy/tree/v0.782/mypy

However, it looks like python3-mypy-0.782-2.fc33 does not have the correct version of python/typeshed synced, which I believe required running `git submodule update` before releasing.

Version-Release number of selected component (if applicable): 0.782-2.fc33

How reproducible: Very

Steps to Reproduce:
As an example, we can compare the vendored `typeshed/stdlib/3/hashlib.pyi` against the expected one from source.

`docker run -it docker.io/fedora /bin/bash -c 'dnf -y install python3-mypy && cat /usr/lib/python3.9/site-packages/mypy/typeshed/stdlib/3/hashlib.pyi'`

Actual results: (attached as actual_hashlib.pyi)

Expected results: https://github.com/python/typeshed/blob/e199c2e4bc95c4df25f0270cedbee934083f4ae8/stdlib/3/hashlib.pyi


Additional info:

Comment 1 Gwyn Ciesla 2021-02-17 14:38:55 UTC
Our package actually uses the python-typeshed package, which is indeed out of date. I'll get an update out.

Comment 2 Fedora Update System 2021-02-17 14:49:24 UTC
FEDORA-2021-7fd67e32f4 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2021-7fd67e32f4

Comment 3 Fedora Update System 2021-02-17 14:49:25 UTC
FEDORA-2021-394b8bc42a has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-394b8bc42a

Comment 4 Fedora Update System 2021-02-18 02:15:07 UTC
FEDORA-2021-394b8bc42a has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-394b8bc42a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-394b8bc42a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2021-02-18 02:17:26 UTC
FEDORA-2021-7fd67e32f4 has been pushed to the Fedora 32 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-7fd67e32f4`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-7fd67e32f4

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Gwyn Ciesla 2021-02-20 21:25:12 UTC
*** Bug 1931044 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2021-02-25 15:50:55 UTC
FEDORA-2021-c7f768573b has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-c7f768573b

Comment 8 Fedora Update System 2021-02-25 15:50:56 UTC
FEDORA-2021-551a1dcc1f has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2021-551a1dcc1f

Comment 9 Fedora Update System 2021-02-25 23:45:32 UTC
FEDORA-2021-c7f768573b has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-c7f768573b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-c7f768573b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2021-02-26 00:45:13 UTC
FEDORA-2021-3048b821bb has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-3048b821bb`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-3048b821bb

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2021-02-26 01:08:20 UTC
FEDORA-2021-394b8bc42a has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 Fedora Update System 2021-02-26 01:09:15 UTC
FEDORA-2021-7fd67e32f4 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 13 Fedora Update System 2021-02-26 01:33:31 UTC
FEDORA-2021-551a1dcc1f has been pushed to the Fedora 32 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-551a1dcc1f`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-551a1dcc1f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2021-03-01 16:48:33 UTC
FEDORA-2021-3048b821bb has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-3048b821bb

Comment 15 Fedora Update System 2021-03-02 15:56:41 UTC
FEDORA-2021-3048b821bb has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-3048b821bb`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-3048b821bb

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Fedora Update System 2021-03-03 23:15:25 UTC
FEDORA-2021-3048b821bb has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 17 Fedora Update System 2021-03-05 19:23:40 UTC
FEDORA-2021-551a1dcc1f has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 18 Fedora Update System 2021-03-19 17:38:32 UTC
FEDORA-2021-c7f768573b has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 19 Fedora Update System 2021-03-19 19:55:48 UTC
FEDORA-2021-c7f768573b has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.