Bug 1929697 - Application startup delay after re-login
Summary: Application startup delay after re-login
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: plasma-workspace
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: KDE SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-02-17 13:21 UTC by nucleo
Modified: 2021-03-12 01:35 UTC (History)
5 users (show)

Fixed In Version: plasma-workspace-5.21.2-1.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-12 01:35:17 UTC
Type: Bug


Attachments (Terms of Use)

Description nucleo 2021-02-17 13:21:39 UTC
Description of problem:
After logout/login all KDE applications started with small but notable delay about 1 second.

Version-Release number of selected component (if applicable):
plasma-workspace-5.21.0-1.fc34.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Login in KDE after boot.
2. Re-login
3. Start any KDE application

Actual results:
If try to start kwrite in konsole it starts with small delay after error message

Qt: Session management error: Could not open network socket

Expected results:
No delay.

Additional info:
In first session after boot no delay in applications startup and no error message.

Comment 1 nucleo 2021-02-17 13:32:33 UTC
If I kill all left user processes after logout and login after that then no delay in applications startup.

Comment 2 nucleo 2021-02-17 13:47:30 UTC
There are user processes left after logout

user       13330  0.3  0.0  19812 11216 ?        Ss   15:37   0:00 /usr/lib/systemd/systemd --user
user       13334  0.0  0.0 171648  3400 ?        S    15:37   0:00  \_ (sd-pam)
user       13369  0.0  0.0   9488  4024 ?        Ss   15:37   0:00  \_ /usr/bin/dbus-broker-launch --scope user
user       13370  0.2  0.0   6028  3400 ?        S    15:37   0:00  |   \_ dbus-broker --log 4 --controller 10 --machine-id 3e41e674aa6d4bb69cb0fb473436db8a --max-bytes 100000000000000 --max-fds 25000000000000 --max-matches 5000000000
user       13451  0.0  0.0 155840  5584 ?        Ssl  15:37   0:00  \_ /usr/libexec/dconf-service
user       13796  0.0  0.0 308292  6556 ?        Ssl  15:38   0:00  \_ /usr/libexec/at-spi-bus-launcher

But all of them terminated after some time.

Comment 3 nucleo 2021-02-17 14:34:39 UTC
Sometimes processes are not terminated

user         672  0.0  0.2  19704 11372 ?        Ss   16:06   0:00 /usr/lib/systemd/systemd --user
user         676  0.0  0.0 242476  3120 ?        S    16:06   0:00  \_ (sd-pam)
user         700  0.0  0.1   9620  4324 ?        Ss   16:06   0:00  \_ /usr/bin/dbus-broker-launch --scope user
user         701  0.0  0.0   6384  3592 ?        S    16:06   0:00  |   \_ dbus-broker --log 4 --controller 10 --machine-id ded605307ba2424e8284f527ca35e8f4 --max-bytes 100000000000000 --max-fds 25000000000000 --max-matches 5000000000
user        1790  0.0  0.3 376856 12740 ?        S<sl 16:08   0:00  \_ /usr/bin/pulseaudio --daemonize=no --log-target=journal

Comment 4 nucleo 2021-02-17 19:56:00 UTC
This happens in x11 session, I am not sure about wayland.

Comment 5 nucleo 2021-02-17 21:09:56 UTC
Variable SESSION_MANAGER is not defined at first login.

After re-login this variable is defined and points to non existing file that was created at previous session and deleted after re-login
local/unix:@/tmp/.ICE-unix/1948,unix/unix:/tmp/.ICE-unix/1948

After clearing SESSION_MANAGER in konsole with 
export -n SESSION_MANAGER
kwrite starts without delay and error message

Comment 6 nucleo 2021-02-25 23:29:48 UTC
Looks like this was fixed after update to 5.21.1, SESSION_MANAGER points to existing file.

Comment 7 nucleo 2021-02-25 23:45:15 UTC
Enforce SESSION_MANAGER is exported before plasmashell is started.
https://kde.org/announcements/changelogs/plasma/5/5.21.0-5.21.1/

Comment 8 Fedora Update System 2021-02-28 15:46:35 UTC
FEDORA-2021-4cb70a50e5 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-4cb70a50e5

Comment 9 Fedora Update System 2021-02-28 19:12:52 UTC
FEDORA-2021-4cb70a50e5 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-4cb70a50e5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-4cb70a50e5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2021-03-01 17:55:54 UTC
FEDORA-2021-4cb70a50e5 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-4cb70a50e5

Comment 11 Fedora Update System 2021-03-02 04:31:02 UTC
FEDORA-2021-4cb70a50e5 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-4cb70a50e5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-4cb70a50e5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2021-03-02 04:44:44 UTC
FEDORA-2021-4cb70a50e5 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-4cb70a50e5

Comment 13 Fedora Update System 2021-03-03 15:42:50 UTC
FEDORA-2021-4cb70a50e5 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-4cb70a50e5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-4cb70a50e5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2021-03-12 01:35:17 UTC
FEDORA-2021-4cb70a50e5 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.