Bug 1929730 - Fails to update vNUMA nodes from number to 0 for running VM (next configuration run).
Summary: Fails to update vNUMA nodes from number to 0 for running VM (next configurati...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.4.4.5
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: ovirt-4.4.7
: 4.4.7
Assignee: Liran Rotenberg
QA Contact: Polina
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-02-17 14:11 UTC by Polina
Modified: 2021-07-06 07:28 UTC (History)
2 users (show)

Fixed In Version: ovirt-engine-4.4.7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-06 07:28:18 UTC
oVirt Team: Virt
pm-rhel: ovirt-4.4+


Attachments (Terms of Use)
engine.log (203.99 KB, text/plain)
2021-02-17 14:11 UTC, Polina
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 114734 0 master MERGED core: update vm vnuma list 2021-05-12 09:01:10 UTC

Description Polina 2021-02-17 14:11:44 UTC
Created attachment 1757569 [details]
engine.log

Description of problem: For a running VM the VNUMa nodes number could be updated from number to number but not to the 0.


Version-Release number of selected component (if applicable):
ovirt-engine-4.4.5.5-0.13.el8ev.noarch

How reproducible: 1. Configure VM with 2 numa nodes , start , 
2. For the running VM change numa nodes to 0 - 'Changes that require Virtual Machine restart:' window appears which is right , but we can already see at this step that the yellow triangle icon of the next configuration doesn't appear.
3. Restart VM - still see 2. 100%


Steps to Reproduce:
1. Configure VM with 2 numa nodes , start , 
2. For the running VM change numa nodes to 0 - 'Changes that require Virtual Machine restart:' window appears which is right , but we can already see at this step that the yellow triangle icon of the next configuration doesn't appear.
3. Restart VM - still see 2. 

Actual results:
After restart we still see the previous number of vNUMA nodes

Expected results:0 for vNUMA nodes


Additional info:

Comment 1 Polina 2021-06-03 10:09:25 UTC
verified on ovirt-engine-4.4.7-0.23.el8ev.noarch

Comment 2 Sandro Bonazzola 2021-07-06 07:28:18 UTC
This bugzilla is included in oVirt 4.4.7 release, published on July 6th 2021.

Since the problem described in this bug report should be resolved in oVirt 4.4.7 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.